How to get started/ upgrade?

Well I’ve been getting use to Linux for a while & I love it.
Now its time for Ardour which is why I originally tried Linux.
I’ve been running Cakewalk software since the MSDOS days & want to ween myself off Windows so
I’m running Ubuntu Studio 7.10 now & everything is working except my DAW.
I’m dual booting with XP & U-Studio & no problems on the XP side.
My M-Audio 2496 sound card works fine in Audacity but I’m lost in Ardour.
I’ve been reading for quite a while about Jack & still have no clue how it works.
If I import a wave file into Arbour I can see the wave & watch the mixer meters jumping on playback but I can’t get any sound to come out at all. I’m assumimg its all in the set-up but I don’t have a clue what to do. Any help is appreciated or even a pointer to some good tutorials. Also I’m not sure how to upgrade from version 2.0.5. Do I just download a tarball & open it or there a safer way to upgrade to ta newer version of Ardour?

First, to get started:
Your problem seems related to Jack and/or your hardware configuration.

Open a terminal and run, as user, qjackctl (if you don’t have this application, install it from your package manager). Click the “Set Up” button.
Open another terminal and check your audio devices with $cat /proc/asound/cards.
0: “whatever device” is what jack sees as interface hw:0
1: “another one” is jack interface hw:1. And so on.
(typically the on-board audio card, if not disabled in the BIOS, is 0)
Assuming you are using the m-audio for playback, check the number given to it. It could be that you have to change the interface in the jack set up.

Once you’ve made sure the jack interface is OK, you might have to tweak some other configuration to get a good performance, but we’ll see.
Click the Connect button. You’ll see the capture and playback devices of your audio card. Open an ardour project and it will show up in this “connect” window. You’ll normally have the master outputs connected to the playback devices and the track where you imported to the .wav file connected to the master inputs. If not, connect them so.

As for upgrading ardour, or you build it from source following the instructions in this site or you just install the binary from your distro, which is far much easier, although I don’t know if the last version is in the Ubuntu repositories.

By the way, support for newbies is great at the forum at
Also this can help:
The 64Studio forum can be helpful too (
I hope this helps a bit.

Thanks for the help.
I forgot about a SBlive card I also had that I rarely use & that was what was defaulted to in Jack. It’s not even hooked up to my sound system. Evidently Audacity recognized the M-audio as the default & thats why I was so confused why Ardour wouldn’t play.
The “cat /proc/asound/cards” did the trick. I still haven’t got it recording yet but I think I’m getting the hang of it.

If I install the binary will it overwrite my existing installation & upgrade or will it install a completely seperate version?

By the way my onboard sound card is also listed & its disabled in the bios.

If you install using the package manager (Synaptic/Software Update/apt-get) then it will upgrade your existing installation - actually there’s a newer version for Ubuntu at than exists in the official repositories.

If you compile from source it’s possible to get it to install wherever you want.


I’ve written a guide to installing and upgrading from Subversion using Ubuntu Studio. It will probably work for other Debian distros but I can’t vouch for it.

Hope it helps.


you can upgrade to the next Ubuntu(-studio) version “Hardy Heron” (will get final release tomorrow) and get ardour 2.3 with that. It’s almost as great as 2.4.1! Also, it’s easy to build your own, all the necessary stuff is downloaded with a simple

apt-get builddep ardour

And from there you can follow ardour’s build instructions. Worked like a treat for me!

to get the sound going, you need to run jack (ardour does that for you if it’s not running already), and to get it operating in “realtime” mode you want to add some stuff to /etc/security/limits.conf which is covered elsewhere.