How to disable midi stretching when changing tempo?

Hello,

I am starting with midi in Ardour (ver 6.5.36), mainly to record e-drums midi signals and later bouncing all that to audio.

I was pleasantly surprised to see that midi regions are accurately stretched when I change tempo by shift-dragging on the bar lines. However, there are cases when I want the midi timing to remain locked, even when the tempo changes.

My usecase: I tend to start by freely recording the drums in order to set the tempo, and after that I adjust the tempo changes in ardour to follow what has been recorded with midi. So in these cases I want the midi timing to stay locked while I adjust the tempo throughout the song.

I have looked around into the settings, context menus, but found no way to inhibit midi stretching when changing the tempo.

I am missing something?

TIA

You’re not missing anything. At this time, all MIDI data is timed in units that are tempo dependent. The units are essentially musical beats, which are only defined in terms of tempo. Change the tempo, you change what a “beat” is.

In future versions of Ardour, it might be possible to specify that certain MIDI data is timed using absolute (audio) time, and then this will not change if the tempo changes.

Thanks Paul!

Looking forward to see this in future versions. In the mean time I will just adopt a slightly different workflow, no big deal.

Regards