How to change Bitdepth?

Ahoi,

I bought a Behringer UMC1820, which is discussed in other Posts here, some did mention clicks and Artefacts which i also experience.
I am pretty sure this lies in the wrong bit depth which is 24 bit in this case, i tryed to change it but somehow alsa and jack insist of 16/ 32bit, in qjackctl where its called “wordlength” this switch is grayed out and i cant change it.

I`d be greatfull for help.

If the bitdepth of the samples changes the behavior of your UMC1820 then it needs to be replaced.

Ardour asks for the maximum resolution (bit depth/sample size) the device can offer. All internal processing in Ardour uses 32 bit floating point. There’s no option to force the bit depth, in general.

Thank you for this quick Response, and your great work in general i really love Ardour!
at the moment i am testing on another maschine and the interface seems to work o.k. ish, with Jack and guitarix, il keep on tryin i have 12 Days left to send it back, maybe i get it workin`
thanks

If you don’t use JACK, but Ardour’s ALSA backend, you can try to set flags the environment variable ZITA_ALSA_PCMI_DEBUG to 2^9 (force 16bit) + 2^8 (force stereo)

ZITA_ALSA_PCMI_DEBUG=768 Ardour6

That should also print debug output about used settings.

PS. what samplerate, buffersize are you using? Is this really a bit-depth issue, and not dropouts?

Thanks for your help, it was just my lousy Mainboard and its shitty USB-Ports. I use a PCIe-USB Card now. :slight_smile:

Great that it works now.

If I may ask, how did you figure this out?

After fiddling around askin DuckDuckGo and here! and there…
I tryed another Desktop and my trusty old IBM T60 and it worked, so i knew it had to be a hardware thing.