How to Arm (Play) Selected Midi Track Only?

Hi everyone,

When I use Reaper back in Windows OS, what I encountered was all midi tracks were armed, and whenever I play a note on keyboard, all midi tracks were playing that note on each VST plugin they currently are running. Fortunately, there was an option that is “arm only selected track”. And that was it, it solved my problem in Reaper.

I’m having the same issue in Ardour 6 (running on Ubuntu Studio 21.04). I added a screenshot down below, as you can see, I have 2 midi tracks each are running separate VST’s. When I select one of the midi tracks and play a note on the keyboard, the other (unselected) midi track also plays that note. I dig everywhere on the manual, preferences etc. but nothing helped me to fix it. I can’t find any topic on the web. So I decided to create this topic.

Thanks,
-Bugra

Terminology note: arm isn’t the right term here.

What’s happening is that you only have one MIDI input device, and both MIDI tracks are connected to it by default. When you press a key, the NoteOn/NoteOff events go to both tracks, with the result that you hear both of them.

There are two ways to deal with this.

  1. In the mixer strip for a MIDI track, right below the track name, there’s a button with something that looks like a MIDI DIN plug. Click it to enable/disable MIDI input for that track.

  2. Go to Edit > Preferences > MIDI Port Config. Enable “Follow Selection” for the MIDI device port in question. It should then be connected/disconnected/reconnected the first selected MIDI track automatically.

2 Likes

Thank you so much Paul. I appreciate your comment, it saved my life.

Best regards