How many channels can I record at once

Hi Guys.
I want to install a daw on my windows laptop which will allow me to record 29 channels simultaneously through a usb interface (allen and Heath Qu32). then once the show is over I need to play them straight back through the qu-32 to re-mix “live” as it were.
My laptop is windows 10 64bit and I have 4G Ram.
I use ardour on my ubuntu studio machine but I get intermittent noise if I connect to the qu-32. A&H won’t support linux operating systems so I thought that I would try it in windows.
Any help gratefully received.

I have recorded 32 channels from a Midas M32 using a pretty old laptop with HDD (not SSD), so unless something is really wrong with your laptop I don’t think there should be any problem. Don’t run plugins while recording, and use the ASIO drivers with relatively large buffer size and you should have no problems.

Thanks Chris. I have downloaded Ardour and am going to see how well it works. With a bit of luck I will have a happy show. Tim

The current record with a HDD on Windows with NTFS is recording 1004 mono tracks simultaneously (with a MADI interface).

Audio data requires very little bandwidth. Assuming 48kHz and float (4byte), a mono channel need 192000 bytes/sec.

A slow USB2 hard-disk has a throughput of 40 MB/sec, that has a theoretical limit of 218 mono channels:
40 [Mbytes/sec] / (4 [bytes/sample/channel] * 48000 [samples/sec] / 1048576 [bytes/Mbyte])

Internal HDDs have a much higher bandwidth, and the limit are seek-times, and with a SSD, the sky’s the limit.

When recording, do as @ccaudle suggested and use a large buffer-size in Menu > Window > Audio/MIDI Setup, to reduce the risk of dropouts. at least 1024, but larger does not hurt.
You can later reduce it to re-mix.

PS. You may like Menu > Session > Lock – That way accidental key presses won’t do anything while recording.

Cheers Robin. Just as a test I have recorded a single channel of audio with a low latency and played it back into a second channel on the Qu32. A full album with no dropouts, noise or glitches. This is a far better result than I got with ardour on my ubuntu studio pc. I think that on that system I am having issues with the linux usb drivers not liking the Qu but that is an issue for a different day. I am now looking forwards to this attempt at recording ( I am a live engineer rather than a studio engineer ).
Thanks for the tip about session lock - I could see that being really rather embarrassing as I wont be watching the laptop while the show is recording.
I may be forced to start some studio writing / recording as I am loving Ardour so far.
Thank you both for your responses. It is a massive weight off my mind.

I have forgotten any additional setup I may have done on my Windows laptop. Is turning off sleep settings manually recommended, or does Ardour have a way to inform the OS that there should be no sleep allowed even if keyboard and mouse are not touched?

On Windows I do not know for certain, but it seems that setting Ardour Preferences > Appearance > System Screensaver Mode to “Inhibit” or “Inhibit while Recording” (default) does the trick.

Tech details:
On Windows that calls


ES_SYSTEM_REQUIRED: Forces the system to be in the working state by resetting the system idle timer (from SetThreadExecutionState function (winbase.h) - Win32 apps | Microsoft Docs).

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.