How is "MIDI input follows MIDI track selection" supposed to work?


(Arnd) #1

Hello,

I try to use “MIDI input follows MIDI track selection” on Ardour 5.10 but whatever I do I’m unable to make it work.

In Edit->Configuration->MIDI Ports I checked the “MIDI input follows MIDI track selection” and I added checkmarks for my MIDI input for “Music Data” and “Follow Selection” and I tried adding and removing MIDI inputs to two test tracks and checked and unchecked the “Enable/Disable MIDI input” but to no avail.

So my question: How is this supposed to work?

Thanks in advance, Arnd


(Arnd) #2

As I assume that it is a bug, I opened a ticket in the bug tracker…


(Paul Davis) #3

It was a recently introduced bug, now fixed again (5.11 will be out this week; the nightly build has the fix already).


(Arnd) #4

Hello Paul, wow, that was really fast (did I say at lightning speed?). I tested nightly 5.10.466 and the problem is fixed. Thanks to both x42 and you!


(Jfgallant) #5

Hey everyone,

I’m running Linux Mint 18, Ardour 5.12 and the suite of software from KXStudio (Jack 2, Cadence, Catia, etc.). I’m also having trouble with the “MIDI input follows track selection” feature…

In a session that I ran a week ago, I could see all of MIDI devices (I have a bunch of keyboards and synths) listed in “Preferences -> MIDI Ports” and I could check the “follow selection” box and everything was working beautifully. Today I opened this same session, and now nothing is listed in either “MIDI inputs” or “MIDI outputs” (both lists are blank). I can’t find what I’m doing wrong.

Note that it’s not that Ardour can’t see the devices: it’s able to play back the recording (MIDI tracks) from this session just fine and I see all the devices in the MIDI Connections window. I’m able to manually change the connections as well. It’s just that MIDI inputs won’t follow the track selection anymore.

Any thoughts what I’m doing wrong? Or is this a bug?
J-F.


(Jfgallant) #6

Addendum to my last post, as I eventually figured part of it out. Hopefully this helps anyone else who experiences the same:

  1. Even though I had not explicitly created any connections to any MIDI tracks before I saved the session, upon reloading it Ardour came up with a bunch of devices already connected to every track. Not sure why. This is not the state it was in when I saved the session.

  2. Although the MIDI devices are still not listed in “Preferences -> MIDI Ports”, I discovered that “follow track selection” still works, actually. As one selects different MIDI tracks (looking at the “MIDI Connection Manager” window at the same time), Ardour removes the connections from the previous track, and creates the desired connections to the newly selected track. And it looks like it remembers which MIDI inputs had the “Follow Selection” option checked in Preferences.

Cheers.