How do you set up MIDI in Ardour?

I am new to Ardour, and I have become quite frustrated in the past three hours attempting to understand MIDI connections. I have used MIDI for several years on pro tools, but pro tools can only run RTAS plugins, and I want to experiment with VSTs. So I decided to install Ardour. I cannot find any description of setting up a MIDI keyboard and connecting it to a plugin that is simple enough for me to follow.

In my current setup I have:

-My Macbook Pro
-Digidesign Mbox
-Yamaha Piano with MIDI I/O
-Condenser Microphone

Currently, my Mbox is being routed through JACK as my input and output for Ardour. My MIDI I/O on my Yamaha Keyboard is physically connected to the I/O of my Mbox with midi cables, and the Condenser Microphone is connected to Input 1 of the Mbox.

I have done several audio recordings on Ardour so far, but I am still clueless on how to setup and use MIDI.

Best wishes to all

have you seen:

in each MIDI track choose IN and OUT devices and channel numbers…

I have tried that, but every time I connect the midi output of a MIDI track to my MIDI input, I get a flashing feedback button.

OK, try this : take 1 MIDI track and check ALL “out” connections, you should only have 1 OUT connected
( sometimes , as default, things are connected and produce feedback

or, : mute all, or start a nex session, create 1 new MIDI track, and take each step ( IN and OUT )–>you’ll discover all what can be routed

sorry sticklefrog, maybe I was to fast:
-JackOSX.0.90b17 should work -> X.9 ( X.8 included )
-here I use X.8, but I couldnt bring it to work
—> so I came back to:
JackOSX.0.90b15, and it works

Update: I did manage to find jackosx 0.90b15, but it still is blind to midi. Other software (which does not rely on jack) works well with my midi device. Any ideas? TIA!

Update (2): ok, I found it (sorry for some thread pollution this caused, maybe we need a post edit feature?)
Apparently I had a jackpilot (or .jackrc) leftover, which caused the preferences screen to not show on jack pilot start. When I deleted all and freshly installed, I got jackpilot preferences, where I could check the “enable MIDI” box and all was well!

Hi JL,

I’m also trying to get MIDI to work (X.9, current beta of A3, jack 0.90b17) and jack seems to be blind to my midi (e-piano via USB). In OSX MIDI setup the piano works (I/O).
If it helps: in qjackctl MIDI is greyed out (set to raw).

I wanted to try jack 0.90b15 but I can’t find a download link anymore… Could you post yours? Thanks a lot!


took time to understand whats going on:
does it help?