How do I start up the JACK server at 96000 Hz 24-bit with Ardour 2

I have been searching the internet for a long time looking for how to start up JACK with 96khz default instead of 48000 for a few hours, and everything I tried doesn’t work with ardour. If I use qjackctl, ardour will say it can’t connect. I made 2 .asoundrc files, one in the /root directory and one in the user /home directory, neither changed the sample rate for some reason. I’ve been looking for config files that correspond to the sample rate for alsa, jack, and ardour, with no luck. What am I missing?

I just tried it myself at 96k (I normally record at 44.1k), via qjackctl, and ardour (2.0beta10) connected and opened up a new session without a complaint.

This is on Fedora Core 6 with the CCRMA repositories running an Ingo rt kernel. The hardware is an RME hdsp/digiface.

I’ve done no special or extra configuration of alsa or any modules.

Can you give more distro/hardware details?

Also, you say that when you use qjackctl ardour won’t connect. Is that at any sample rate or just 96k? Does qjackctl start jack and run nicely on its own at 96k?

Let me know if there’s a config file I can look at for you.

Ok I think I found my problem. Qjackctl can’t use realtime processing when I run it as user, so it starts then stops. I can’t run Ardour as a user if I run jack as root, it says that the device is in use. I can’t run ardour as root, it says command not found.


Oh yeah, I’m running Gentoo with the 2.6.18 gentoo kernel with an Echo Mia sound card.

Yes, that’s a security issue that different distros handle differently, I believe.

Here is a link explaining how it’s handled in fc6/ccrma:

I don’t know if it applies to gentoo or not.

Are you able to run qjackctl or ardour at any sample rate at all?

Ok thank you for your help. I had to recompile my kernel to allow for realtime support. I somehow missed this page in all my searching: