how do i run import an audio file in ardour (bug?) / how do i run an svn installed ardour?

the reason for the strange headliner of my post is that firstly i couldn’t import a single audio file since the the import menu didn’t provide me with the track/ region menu as shown in the manual and it just gave me a blank window with 4 faint-lettered options and with only apply and ok buttons working. no file browser no nothing.

i considered this a bug so having the 2.5 version of ardour i downloaded the the latest by svn but although i can see a file name 2something going on i can’t run it!!
please help in any of my two problems!!

especially for first i have tried all possible ways so it’s not that i meddled with any of configurations and with the svn folder i have tried the ./configure make make isntall way and it doesn’t work

I’ve seen this problem after upgrading my Ubuntu from 8.04 to 8.10. I tried renaming my .Ardour settings folder but that did not fix the issue. I’ll likely just try to build the more recent version as the version is:

ardour 2.5
(built from revision 3525)

Free Image Hosting at

man, build instructions are described in this website. It’s OK you ask for help but a little more exploration of this site would be fair to try first.

yes i guess you would be right but building such a program for a noob can be hell especially when errors occur that simply cannot be found anywhere in the internet!!
although several depedencies we reported missing (sometimes not that clearly) i finally began building when such an error came up:

In file included from libs/vamp-plugins/plugins.cpp:44:
libs/vamp-plugins/Onset.h:21:25: error: aubio/aubio.h: No such file or directory
In file included from libs/vamp-plugins/plugins.cpp:44:
libs/vamp-plugins/Onset.h:56: error: ISO C++ forbids declaration of ‘fvec_t’ with no type
libs/vamp-plugins/Onset.h:56: error: expected ‘;’ before ‘’ token
libs/vamp-plugins/Onset.h:57: error: ISO C++ forbids declaration of ‘cvec_t’ with no type
libs/vamp-plugins/Onset.h:57: error: expected ‘;’ before ‘
’ token
libs/vamp-plugins/Onset.h:58: error: ISO C++ forbids declaration of ‘fvec_t’ with no type
libs/vamp-plugins/Onset.h:58: error: expected ‘;’ before ‘’ token
libs/vamp-plugins/Onset.h:59: error: ISO C++ forbids declaration of ‘aubio_pvoc_t’ with no type
libs/vamp-plugins/Onset.h:59: error: expected ‘;’ before ‘
’ token
libs/vamp-plugins/Onset.h:60: error: ISO C++ forbids declaration of ‘aubio_pickpeak_t’ with no type
libs/vamp-plugins/Onset.h:60: error: expected ‘;’ before ‘’ token
libs/vamp-plugins/Onset.h:61: error: ISO C++ forbids declaration of ‘aubio_onsetdetection_t’ with no type
libs/vamp-plugins/Onset.h:61: error: expected ‘;’ before ‘
’ token
libs/vamp-plugins/Onset.h:62: error: ‘aubio_onsetdetection_type’ does not name a type
scons: *** [libs/vamp-plugins/plugins.os] Error 1
scons: building terminated because of errors.

i searched everywhere for the terms and could find nothing!!

install libaubio and libaubio-dev before compiling ardour.

If you are running a debian based system, run the following in a terminal

sudo apt-get build-dep ardour2

it should install all the dependency packages for compiling your own ardour2.

re:import … what Linux distribution is this?