How do I record a seq24 Midi-Pattern 100% on time with Ardour?

Hi @ all,

i spent the weekend playing with seq24, Qsynth & Ardour. I’m running Ubuntu 9.10 Karmic Koala with Ardour 2.8.2
(built from revision 5396) installed from the Repositories, as seq24, JACK, Qsynth and RealTimeKernel too. Am taking notes on that subject over here: .

I am able to record my seq24-Songs with Ardour, but i am absolutely not satisfied with the TIMING.

To take the easiest example: a simple Beat Pattern consisting only of 3 KickDrums and 2 Snaredrums.



  • Positional Sync Source = JACK
  • Time Master = ON/Green


  • File -> Options -> Jack Sync
  • checked Jack Transport & Song Mode, then hit CONNECT and then OK

By doing that i “enslaved” seq24 with Ardour, and can control it via Ardour-Transport-Buttons :wink:

Now i take a new Stereo Track, take the Qsynth-Output as Input and start recording that pattern for 20 Bars.

Everything runs well, i got a super-clean and extra-crisp drum-pattern recorded in Ardour now - BUT: the Kicks and Snares are NOT 100% on Beat - they are in fact swinging, which might be nice if i wanted that, but i don’t.

So what am i missing? Do i have to set different settings in Ardour

  • Options -> Timecode fps ->? (is now on 30 fps)
  • Options -> Sync -> ? (is now on Send MMC & Use MMC)
    Or in seq24:
  • Options -> MIDI Clock -> ? (is now on ON (Pos) for all 16 Qsynth Midi-Channels and Clock Start Modulo 64)

Does anybody have the same issues? Please post here.
Does anybody has mastered recording seq24-Patterns in Ardour with 100% correct timing? Pleas post here.

I read a few things about “seq24 being buggy” - is that true - what are these bugs - might that be the cause of my problems?

Hoping for Hints :wink:

Hey jonobo:

I did myself have quite some problems with seq24. I downloaded the latest version from

which I think Karmis should have.

What I had to do is set seq24’s options like this:

Enable Jack Transport
Enable Transport Master
Enable Master Conditional
Enable Son Mode

Then hit connect after firing and setting up ardour the way you did above.

Master Conditional will make it be Master only if no other JACK Transport application is running at the moment. For me that worked well, used to be offbeat also.

Good Luck!