How do I make Plugins work!!

I downloaded many plugins (calf etc…) using the synaptic package manager in ubuntu. I have ardour working with my audio interface. When i open an audio track for my guitar and turn on a plugin, i do not hear any difference between the clean guitar, and the guitar with the plugin on. Ie the plugin does not work for me. Am i missing something? How do i make them work?

Did you create a bus track for monitoring?

Then connect input (guitar) to bus and effect in output of bus.

Effects can’t be heard in real time in an audio track, only when you record onto it and then play it back.

Make sure the plugin is activated (right click on the plugin, select ‘Activate’ from the menu)

@joegiampoli: not sure what you mean about “effects can’t be heard in real time”. They are applied to the monitoring signal path as well.

@Paul, he’s talking about tracks with effect plugins but in “hardware monitoring” mode.
Only in software monitoring will you hear the FX in realtime. It is not about recorded material but a realtime external source connected to the track inputs.

@ Paul:

I meant exactly what thorgal says, just didn’t put it in right words, or described in a deeper way, I woke up on the wrong side of bed today :frowning:

Why do you have to use a bus for monitoring? What does a bus actually do? I am very confused about all of this routing the signal to different places. Why can’t I just apply the effect to my audio track and hear the audio track with the effect on it while I am recording? Thank you very much in advance!

@ Paul:
First of all thanks! Second, am I using h/w monitoring if I am using a bus? Do you have any suggestion where I could learn about all of this signal routing and busses and monitoring and whatnot? Thanks!

You can, go to the Options menu and make sure that option(Run plugins while recording) is activated under Misc Options IIRC.


@tnasty: either you are monitoring via ardour, in which case you do not need a bus at all and your FX will all be audible in realtime, while recording OR you are monitoring using h/w and thus you are not listening to any signal path that is routed via ardour. Thus bus suggestion was a bit misleading without more context. The default setting in Ardour is h/w monitoring - there is no good default choice for this. Options -> Monitoring to reset it.

@tnasty: using a bus has nothing to do with monitoring. Just go to Options -> Monitoring and it will show you what you are currently using. You sound as if you want “Ardour does monitoring”. The old manual (see has some info on monitoring but I am not sure if you will find it helpful.

@ Paul:
Wow that is exactly what I wanted to do thanks! I can hear the effects while recording and I can change the settings, or even take all of the effects off, after the recording is done. Why would anyone want to use hardware monitoring where you couldn’t do this? Also, I will have a look at the manual. Thanks a lot!

You would want to use hardware monitoring for near zero(Or zero) latency monitoring which is important in many setups.