How do I make Ardour activate/see my Faderport 8 under Jack?

So I got Jack (in QjackCtl) running with help from the community, and it’s been really nice! But after I’ve started using it, Ardour won’t register my Faderport 8 control surface.

In the “edit>preferences>control surfaces>FP8”-field, I can only choose "Incoming MIDI on “x-virtual-keyboard” and Outgoing MIDI on “physical_Midi_Input_monitor_enable” for the Faderport 8. Even when I start the FP8 before I open Ardour.

Can somebody please help me make it work again?

Besides the FP-8 I run a Focusrite Scarlett 2 3rd Gen.

I’m not quite on par with the situation these days, as I’m using Pipewire which nicely glues all that Audio and MIDI mess together for me.

But if I remember correctly, JACK2 MIDI doesn’t support hardware ports by itself, you’ll need to start a so-called ALSA MIDI bridge, I always used “a2jmidid -e” for that, from the qjackctl setup dialog/post-start script option. JACK1 has more or less this same code built in, I don’t remember if you need to activate it by commandline or anything, though.

Sounds nice with Pipewire, but for one that has trouble making QjackCtl work, I fear that it will be to heavy for troubleshooting for me.

Do I just add that ALSA MIDI thing there to the post-start script (pactl load-module module-jack-sink channels=2; pactl load-module module-jack-source channels=2; pacmd set-default-sink jack_out;) that I already have?

You’ll probably first have to install the a2jmidid package via your package manager, and then yes, add it to that commandline you have, separated by a semicolon like the other commands. Also add a trailing ampersand to have it running in the background - otherwise qjackctl will seem like hanging until a2jmidid is stopped/killed again. So try adding “; a2jmidid -e &” (without the quote marks).
You also can run “a2jmidid -e” in a different terminal window once the jack server is started. That post start skript option in qjackctl is just a convenient way to do the same.

Thanks for the thorough explanation. I tried doing what you said, and while I did get more options in the FP8 menu in “Edit>preferences” no selections, or indeed combo of selections, make my FP8 spring to attention like it used to. It still says “waiting for host” on its display…
What can I be doing wrong?

Edit:
I just needed to reboot ardour, it seems. Now everything is working!!
Thanks :slight_smile: :smile:

@edogawa hm. I spoke too soon… With the “&” at the end, it doesn’t work. And without it, it does indeed spring to attention, but takes no commands.
What can be the issue?

I suggest to use Ardour’s ALSA backend (no JACK, no Pipewire).
That is a lot easier to setup and MIDI works directly without any additional setup.

Make sure that jackd is not running, start Ardour, load a session,
The engine dialog shows, select Audio-System: ALSA (not JACK), MIDI-System: ALSA Sequencer.

Connect the FaderPort in Preferences > Control Surfaces, and check if the FP8 works (it should), and only later if you really need JACK, investigate how to set JACK-MIDI up properly.

Thanks. That’s what I ended on also. It’s a bit more clicking around, to
use Jack when needing to record from other software and use Alsa when
editing. But I guess that’s just how it is.

cheers!