How do I install the lv2 plugin Noise Repellent in Ubuntu Studio?

I moved to Ubuntu Studio 20.10 in October to take advantage of Jack and Ardour for podcast editing, at least at first. I’m newer in Linux but I am getting comfortable in Terminal. Jack is driving me crazy, but that’s another post. I’m using Ardour from the repo so it’s currently 6.3.

I moved from Audacity, but Audacity has an effect called noise reduction, and the only similar lv2 plugin I’ve found is called Noise Repellent. See their Github page.

I have spent days trying to install this plugin and have failed many times and in many ways and I just can’t figure it out. Is there someone here who has run into this issue. Maybe there is another noise removal tool but this one looks great.

I’ve done a few “git clones” successfully so I tried to build this using the exact directions on the Github page. When it tries to build I get a few errors, you can see below.

TLDR is Program sord_validate found: NO and Run-time dependency fftw3f found: NO (tried pkconfig and cmake)

I can’t find anything about a sord_validate program, but when I look up fftw3f I get pretty scary messages about don’t do this unless you are an advanced user. OK. I’ll try something else.

I asked a friend who knows more and they suggested I just download the zip file and unzip it in the correct directory where the lv2 plugins are located, so I did that.

I was able to open Ardour, scan for new plugins, find Noise Repellent, then try to add that plugin to a track, it appeared in the plugin manager window, but when I try to add it to the track, I got an error message. The Plugin Noise Repellent could not be loaded, check the log files.

When I checked the log file the error said Failed to Instantiate Plug in.

I’m lost. It seems like it should be so easy to add additional plugins into Ardour.

Is there another way I’m supposed to be doing this?

Why is a noise removal tool not included by default, that seems like an essential plugin?

Because that would tie release cycles of the plugin with Ardour releases.

We do not ship plugins that are developed by 3rd parties without affiliation with Ardour because that cannot be maintained, and also only include bread and butter (EQ, compressor, reverb) tools that are mostly neutral.

GNU/Linux distributions also prefer separate packages instead of a monolithic one.

It generally is, but compiling them from source usually isn’t.

Have you tried getting it from your distribution instead? Or maybe get it from


Right now you’re missing the fftw3 development package.
If you run
sudo apt install libfftw3-dev
in a terminal you should be able to get past that particular point in the meson config.

As Robin points out it may be easier for you to get a pre-compiled package from the distro.

1 Like

Thanks everyone for the replies. They truly help me understand this all better. IN continued searching, I discovered the main issue, which allows me to just use the zip file instead.

The zip files are listed as x386 and AMD64, since I’m on Intel and NVIDIA, not AMD, I chose the x386, but that’s a 32 bit version. Nothing was clearly labeled, had it been labeled 32 bit, I would not have downloaded it. That said, I probably still wouldn’t have downloaded the AMD one either since I’m not on AMD.

I downloaded the AMD64 zip, extracted it, move it, and now the plug in works as expected.

I was truly about to just give up.

When you say get a pre-compiled package from your distro, do you mean by searching in the software center? If I search in Discover, since I"m using Ubuntu Studio, nothing comes up for Noise Repellent. Maybe you mean some other way.

Intel (and VIA) copied AMD’s design for their x86_64 chips. The canonical name for 64bit x86 architecture is “AMD64”.

Also many GNU/Linux distros use that name for Intel 64bit systems. e.g

That is great to hear! Have fun mixing.

1 Like

That’s super important to know, thanks.

The x386 and AMD64 labeling can be confusing because you need to know that 386 is a 32-bit CPU and that AMD developed the 64-bit instructions we’re using nowadays.

The easiest way is to see if the software center has the package you’re looking for.
In this case you did the next best thing and downloaded the binary from an external web site.
The most difficult way is to compile it; you need to know about development packages and which to install prior to the compilation.

I don’t generally try compiling stuff first, but I have been successful at it, though I much prefer either from the repo or a zip. I’ll try anything, if it breaks I have backups, that said, I have imposed a self ban on using DD in terminal

Also, I’m new to these forums, is there a community norm to mark something as resolved once it is no longer an issue?

That would be a bug report, which would belong at This is just a discussion forum.

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.