How do I install LV2 plugins?

I have downloaded some plugins which are in standalone, LV2 and VST format. However, I cannot seem find any instructions on how to install them! so the obvious answer is: How do I install these plugins??

I am fairly new to Ubuntu 13.04, so if there is a step by step solution to this, I would much appreciate it!

I downloaded the plugins from the “Distrho” website and it comes in zipped/compressed folders with 3 sub-folders (VST, Standalone and LV2).
The plugins are:
Artican “the pilgrim” and “the function”
the Distrho plugin pack
Highlife
Juced “eqinox”, “drumsynth” and "capsaicin
The TAL plugin pack
and the wolpertinger

I just want to install these so that i can use them… whether it’s the LV2 plugins or VST doesn’t really matter as long as it works.

Help > Reference leads to http://www.manual.ardour.org/working-with-plugins/getting-plugins/

see "How do I Insall plugins"

It doesn’t say how to install anything :-S It only tells you the location it should be installed in and that’s the last step as far as I know.
I have no idea how to compile software… so can somebody please present some easy steps I can use?

Thank you LeatusPenguin that was excactly what confused me!

I’ll some of both I guess

I tried copying the lv2 plugin-folders to “usr/lib/lv2” but nothing happened?
do I need to need to do the same with the VST and standalone folders as well?

augustfrancke: depending on which linux distribution you have, /usr/lib64/lv2 may be more appropriate (particularly if /usr/lib64 exists). it also depends on where you got ardour from. if you got it from ardour.org (the only way that we offer any “official” support), then it will search all over the place for LV2 plugins. if you got it from your linux distribution, it may be more limited in the locations it looks for LV2 plugins and you will have to check with the package maintainers on your distribution.

Thank you Paul!

I got Ardour from ardour.org but there aren’t any plugins showing. And I tried opening /lib64, but there is nothing but a file called “ld-linux-x86-64.so.2”.

@augustfrancke: to copy files to system folders such as /usr/lib/ you will almost certainly need root (admin) access - you can do this from the command line like this:

sudo cp -r my-cool-lv2-plugin.lv2 /usr/lib/lv2

where my-cool-lv2-plugin.lv2 is the name of the plugin, (and / or the complete path to the plugin).

when you run the command you will be prompted for your normal user password.

1 Like

Would that be the same as doing “Alt + F2” and running gksu nautilus?
I figured it out! :smiley: finally!
I installed the KXStudio repos and then i installed all the ones I wanted from Ubuntu Software Center.

Yeah… I just clicked the downward arrow next to “all software” and went in to the “kxstudio” tab and the “plugins” tab.
However, I seem to have encountered a new problem.
I tried installing the KXStudio desktop, but it changed some settings and killed the audio?.. when I open sound settings there is nothing to “play sound through” so I tried removing KXStudio, but nothing changed.
Kinda takes the fun out of uing Ardour :-/

your best asking this over at the kx studio forums on linux musicians. FalkTx will be able to help you fix any problems you have .

With KX studio jack is running all the time, so jack is using your soundcard. If the jacklsa bridge is not running, then non jack aware programs wont be able to play sound.

You can check that its running by opening up cadence, and under jack bridge, Alsa Sound click start if its not already greyed out. That will start the sound loop deamon for routing also audio through jack.