How do I get plug-ins for Ardour

I’m a new Linux user running Ubuntu 9.04. On the recommendation of various user forums I have Ardour, Jack and Jamin installed.

I want to be able to use some good eq plug-ins. jamIn seems to have just that. My Misc Options in Ardour tells me I have plug-ins acticve but can’t locate any anywhere.

In simple terms what do I have to do to get Ardour running with some decent plug-ins and working with JamIn or is this impossible?


I have the plug-ins installed. Don’t seem to be having much success in getting any of them to work. In fact, all that’s happened is that I’ve lost sound on playback.

Also I wasn’t aware that there was no real time control, as with Waves plug-ins for example.

I can’t find a manual anywhere so I’ll have a few more tries then get back to Wavelab (no offence!)

I downloaded a dsp plug-in as recommended. This went into a folder deep in the bowels of my system. To be honest I haven’t got a clue how to get at it. The manual is like Klingon to me but I’ll have a go, once I get ‘root access’ and find the console window

Like I said, I’m a newbie. Not doing too well, am I?

I’ve made some plugins which you may find useful - they are jack applications so as peder says you will have to create an insert point and connect them in like you would for jamin. There are full instructions with them and they’re free to download. They may be a bit ‘heavy’ for lots of channel use in which case you may be better with LV2 style plugins but they should be good for most tasks. There’s an EQ, reverb, compressor and a few other things. You can find them here:

Hope you find them useful.

Assuming you have some LADSPA or LV2 plugins installed you right-click on the empty square above or below the fader on each channel strip (in the Mixer view), choose New plugin and select one.

As for Jamin, that’s a separate program that you start and then connect by adding an insert on the Ardour channel. It’s a fairly heavy program so it’s not recommended to use it as an EQ on every channel. It’s primarily used as a mastering tool and there are other dedicated LADSPA/LV2 EQ’s that are better suited.

Mopani: I’m not sure the Ardour forum is really the right place to discuss what are essentially support issues for my software - although there are many helpful people here who can offer advice, if you require help installing my software, it may be better to use the ‘Contact Us’ button on my website to send me an email and I will be happy to help you get things working. Follow this link…

And click on the ‘Contact Us’ button at the top of the page.

I’ve located the file on the firefox download window, but clicking on it does nothing. A right click allows me to delete so I’ll do that and try again.

Thanks for both replies. I’m getting a feel for the game.

I’ve got eq2 i586 in my sights. Clicking brings up the UI for the plug-in. Very nice. As for installing it, I tried some of the instructions in the user manual to no effect. …

I also tried copying and pasting the file into usr/bin but that didn’t work either and I’ve a feeling it’s not supposed to.

Firefox is a bit unintuitive in its default setting; it automagically download files to the desktop. That’s probably why mopani feels it disappeared.
You should have an icon called there, doubleclick it and you should have an archiver starting, allowing you to uncompress the file. Then it’s just a matter of deciding where to put the files and then doubleclick the right one (start with GR-EQ2/gr-eq2_i586).

@mopani: downloading files with your web-browser does not install them on (on Linux). This is one of the most basic elements of network security, constantly violated by Windows. Your browser would have asked you where you wanted to put the downloaded file - it is assumed that you would pay attention and notice the destination folder. If not, there are ways of finding it; the simplest is probably to bring up the downloads dialog of firefox (Ctrl-y) and use that to determine where it put the file. I repeat that downloading files in your web browser does not and should ever install anything (other than browser add-ons, probably).

OK thanks again folks - two comments this time.

First to linuxdsp. I downloaded GR-EQ2 from your site and the file disappeared into a folder my system. I can’t locate it now, though a friend told me how to access my folders, but even then I wouldn’t know where to look. It obviously hasn’t installed as even I have been through some successful installs to date and know what happens. Even so I had a look and I can’t find it in Ardour or Audacity. I’ve opened JACK, but there’s no sign of it in any of the windows or buttons or there. So ‘download’ obviously means something new to me and I’m keen to find out what the secret might be…

Secondly, plug-ins and real time. My fault here - I didn’t clock on to the slider operation That’s my main headache over. I’m impressed by the quantity of plug-ins available and I look forward to sifting through the eqs. I’m sure there must be some quality stuff in there.

I’m warming to the task now and once I get the download bit sorted and have a read around the operation of JACK I think I could make good use of Ardour so thanks again for taking time to reply.

@mopani: There’s not much more to installing the linuxdsp plugins than copying a file. They are standalone applications which you connect up using JACK. Its a very similar idea to connecting real effects units into a mixing desk with patch cables. One of the most powerful features of unix-like operating systems is the ability to connect smaller more specialised applications together to get the task you need done, as opposed to using one massive monolithic application. For example, using JACK, you can connect Ardour, and many other linux audio applications together to form a complete virtual studio setup. With this power and flexibility there is a little more work involved, but the results are usually worth the time spent once you get used to the idea. If you have any problems with the linuxdsp plugins, you can contact me via my website or forum, (I am the developer) and I will be happy to answer your questions.

@mopani: no, you can change the parameters in real time, during playback, either via the GUI or you can bind any of the plugin parameter controls to a MIDI control surface and control it from there. This is all described in the ardour manual (to some extent, anyway).

Note that plugins can be bypassed, in which case they will have no effect on the sound.

And yes, since you are using software that comes from a variety of sources, then you are necessarily going to find that information about the software tends to be dispersed too. No different really than using Waves plugins inside ProTools with a Mackie control surface - you’d need to get info from at least 3 sources to figure out how it all works (together).

Thanks again for the helpful replies. I’ll get some detail next time I fire up my linux laptop. Just for the record I’m well clued into dsp and the rest. I’ve got a PhD in electroacoustic composition so the problem isn’t unfamiliarity with audio software. Everything just seems to be so laborious and connecting things together involves finding information from a variety of resources but maybe that just goes with the territory.

As for the real time bit, if I click on a plug-in (any one) in the mixer window, up pops a small window with parameters. That looks to me like something you change first and then listen to afterwards, ie. not real time, though even then I’m not sure I heard much difference in the sound after a quick try out of some of the eqs.

But like I said I’ll give it another hour or so and get back with further queries.

Once more sincere thanks for taking time to answer my questions.

mopani, if the question was for an Ardour manual there is an old and incomplete, but perhaps useful in your case, here :
How to use (most of) the plugins should be pretty obvious if you have ever worked with digital or analog effects before.


  1. there is real time control
  2. there are no manuals for any (open source) plugins that i know of. there are lots of books on audio engineering, even some good online material. you should probably be reading them if you haven’t already.
  3. if you lost sound it probably means that the settings on the plugin are wrong.

When reporting issues like this, you need to be a LOT more specific. What plugin(s)? What actions did you take? What type of track did you add them to? What was its I/O configuration? More detail is almost never too much.

Many thanks for those helpful replies. I’m on the case. …

It sounds like you installed Ardour etc. into vanilla Ubuntu… in that case, you might not have any plugins installed yet. To install most of the plugins packaged for Ubuntu, go to System > Administration > Synaptic Package Manager and look for & install the metapackage called ubuntustudio-audio-plugins. Then you should see plugins show up in the “plugin manager” when you right-click above or below the fader in Ardour’s mixer.