How do I get jack to automatically connect tracks to sound card outputs

I’m running Ardour 2.41 on Ubuntu 8.04 – it is a backport! When I create tracks in Ardour jack doesn’t link them to the sound card outputs. I have to go into the jack “connect” menu in qjackctl and connect each to playback 1 and 2 to get stereo – I have to do this for each track I add otherwise there is no sound. Can this be done automatically? (Surely it can because I run Ardour 2.41 on another Ubuntu 8.04 machine and it connects transparently.) I am running this on … gulp! … a Thinkpad T30 with an Intel 82801CA-ICH3 sound card … perhaps I should be happy I have sound at all. (And yes I can get useful work done with Ardour and the T30, although I do prefer my desktop with 4 processors and lots of memory.)

You’ve apparently turned off the option in the new session dialog without realizing it. The default is to do just what you describe. When you create a new session, click on “Advanced” in the new session dialog, and pick

* Create master bus
* Automatically connect outputs to master bus

This will connect each new track to the master bus, which will in turn be connected to the first two “physical” outputs that it can find.

This is the default configuration, which matches what most of our users want. You will see other options there too.

Paul, Thanks for the prompt reply. This indeed worked when I created a new session. This leads me to two further questions:

  1. For the already created session, which does not connect, there is no opinion on opening to set this automatic connection. Once opened one can go to “options: autoconnect” and choose this … BUT it only works for new tracks added to the session, any previous made tracks don’t connect.

  2. How do I set the default so that on creating a new session it defaults to automatically connecting. Right now I have to do this manually every time. I have search through config files and searched the web, but don’t see how to set the defaults for the sessions.


Sorry to post again: It appears that my session that did NOT have connections had no master bus – don’t know why this is no doubt advance operator error … and no it doesn’t appear to be hidden … so when I open a new session the master bus appears and everything is fine and dandy. The default for Ardour is to automatically connect the master piece.

you cannot change the connect status of existing tracks in this way - you have to manually connect them.

the default should stick after you make changes to the new session dialog.

Is there a way to pick which outputs to use. On my M-Audio NRV10, the “main mix” is outputs 9-10