How can I sent a MIDI Keyboard to Multiple MIDI tracks at once

I’ve got the desire to play my MIDI keyboard and have track 1 an organ; track two, strings; track 3 Trombone, and even more tracks beyond that with different instruments. I want to have them all sound all at once with my playing the MIDI keyboard.

I thought this would be strait-forward, but I’m missing something. In the drop down in the Mix panel, I have two channels that work, but only when selected can I hear them, just one at a time.

If I choose from the drop down of a MIDI track in the mix screen a “Juno DS” keyboard, it only allows that to be entered but once. Maybe I need to create multiple MIDI inputs, or ports? But in my Mac OSx MIDI, I have no such options, it seems right here in Ardour do my answers lie, but I don’t know where they are.

I almost grasp part of what I’m missing from posts like this, but I’ve not quite figured it out.

If the screen shot is helpful for anything, I include it:

Disable Ardour Preferences > MIDI > MIDI input follows MIDI track selection

When enabled, selecting a track exclusively connects the MIDI sources to that track.

Thanks for the rapid response. I did that, and between my post and doing that, somehow I lost sound output by any means. I closed down that file and opened a new session, still no sound, though I see the input signal goes live (audio levels) when I’m playing the keyboard. I can imagine posts like mine would be aggravating to look through. Possibly, due to glitches, to my defense, there may be inconsistencies with software or devices. I’ve lost audio, for example, before, and totally shutting down Ardour then restarting it brought audio back active to my speakers. I’m ignorant enough to not be able to know user error from software or hardware issues.

One problem solved, but no audio sounding for me.

None of the MIDI tracks have a synth plugin.

Usually when adding a MIDI track an instrument plugin is added, it appears you have selected “-none-”.

Double click the processor-box (large black area in each strip), and in the plugin-selector pick a synth. Compare to

Just before seeing this post of yours, I added two more tracks, and both play, and both do have “Master” selected at the bottom. The first and original MIDI tracks in this project, I show here the menu that appears from that drop down at the bottom. Should “Master” be one of the options?

Oh, shoot. The drop down menu didn’t screen capture.

Well, for what it’s worth, I deleted out the first tracks in this session which though they showed MIDI input in the audio levels, I got no sound out, nor did they have the option in the mixer window in the drop down that you showed, of setting those tracks to “master.”

All subsequent tracks are doing exactly what my design and object is, all different sounds or instruments, and every one taking a feed from my MIDI keyboard, played all at once as a great symphony and orchestra.

Thanks Robin, for your ever superb feedback and productive input.

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.