how can i get the video monitor working?

i really appreciate the new video functionality in ardour, i work with videos quite often and although xjadeo is ok, this could save a lot of clicks.

however, i seem to be unable to get it actually working. when i load a video file, i can see the video timeline with frames from the video, but when i play the session, there is no video window appearing anywhere. yes, Video Monitor from the Window menu is checked. when i uncheck it and check again, ardour usually crashes - console says:

ardour-3.3: ../libs/ardour/ardour/audio_buffer.h:38: virtual void ARDOUR::AudioBuffer::silence(ARDOUR::framecnt_t, ARDOUR::framecnt_t): Assertion `_capacity > 0' failed. Aborted

this also happened once during the transcoding.

tried it with with several files and various transcoding options, in a clean session with nothing but the video in it. in some cases, ardour doesn’t crash, just reports to be diconnected from jack, Log says:

[ERROR]: JACK: zombified - calling shutdown handler

although qjackctl shows jack peacefully running with low load and not a single x-run.

my setup: ardour 3.3, AMD box with fresh instal of AVlinux 6.0.1, Echo Audio fw sound with ffado drivers, ATI video with proprietary drivers.

some ideas? do i miss something?


out of curiosity, i’ve just compilled ardour 3.3 from source and in this build, video support works like a charm! all the issues described before happened in an install from the package downloaded from ardour website (ie. Ardour_32bit-3.3-dbg in my case), so it looks like there’s something wrong with the package, not with my system and/or ardour code.

You downloaded the 32bit version, it’s not as simple as your system being 64 bit is it ?

AMD box with fresh instal of AVlinux 6.0.1,
I think AVL is 32Bit only

yes, AVL is 32bit only. my hardware is 64bit but with AVL installed it acts like an ordinary 32bit system.
i really tend to think there must me something broken in the package. (btw. with packaged ardour3.2 on AVL 6.0 it was the same problem).
anyway, for me the problem is solved now, but if there’s some other information i can provide to help with this, i’ll be happy to do so, i’d just need to be directed somehow, my dev skills are zero.

I have a similar issue here, I can import the file and see the video in the timeline, but the monitor doesnt pop up! its ardour 3.3 on avlinux…


I’m a little confused if you guys are referring to the Ardour debs pre-installed in AV Linux or the binaries provided here at I will say that although I do provide Ardour packages (especially the optional VST build) I really do recommend that people use Paul’s binaries because everything including the Video timeline stuff is getting a bit tricky to package separately (ie having the correct harvid binaries and Xjadeo versions present across the various Ardour updates).

Regardless of whatever efforts I make Paul and the team no longer prefer or support independent packaging of Ardour and fully support their own binaries so users are always best advised to use them instead.

@ Gmaq no I use binaries downloaded from and installed on avlinux…

GMaq, yes, as calimerox says, binaries from are concerned. sorry if it wasn’t clear.

3.4 ( binaries) - same problem like 3.3 (no xjadeo window pops up)
3.4 (built from source) - cannot load video file (ardour log says something like “problem parsing video file”). 3.3 built from source works fine with the same sessions/video files.

Long story short, xjadeo from requires a X11 system from 2009 or later (avlinux which is based on debian/oldstable does not feature that).
As workaround you use xjadeo that comes with avlinux itself. To do that remove the version shipped with ardour.

 sudo rm /opt/Ardour-*/bin/xjremote

and re-start ardour3.

PS. You may need reset video-montor settings in Ardour3-menu > View > Video Monitor > Original Size when loading a session that previously had a non-working video-monitor.
Tested with AVlinux-6.0.1b and official Ardour-3.4, 3.5


As I’ve said before recommend people to use the bundles with AV Linux to ensure support from the Ardour developers. I will point out in the case of Ardour 3.4 and 3.5 specifically the custom AV Linux Ardour and ArdourVST packages work properly with Xjadeo and the Video Timeline OOTB, so if you want to use Xjadeo with the Ardour bundles follow the instructions from x42 above, if you want everything to ‘just work’ in this isolated case you can find all the necessary updates in the AV Linux ‘HotfixUpdatePak’ detailed here:

thank you guys, both solutions work fine!

GMaq: do you plan to provide these “hotfixes” also for the versions of Ardour to follow?


As the gap between the libs in AV Linux and the libs used by the Ardour developers widens I can’t promise anything but to simply see what happens with every new release, I will build alternate packages as long as they will build and work properly. For now Xjadeo can be worked around, it is very likely the the Ardour (and Mixbus) bundles will continue to work on AV Linux for quite some time, but there are no guarantees.

Thanks x42, mv/rm’ing xjremote worked great for me on Ubuntu 14.04 64-bit.

Just wanted to add $0.02 here…my xjadeo was not launching after I did dist-upgrade, to ubuntu 14.04. Thanks to excellent guidance from the redoubtable Robin Gareus on the ardour IRC channel, I removed the xjremote binary as mentioned above and then reinstalled xjadeo ( sudo apt-get install xjadeo). Problem solved. Thnaks, everyone!


I’m on mac intel 64, ardour 4.4, just testing the demo version and the video view is nowhere to be found ;/
The timeline shows the video, but whatever I try to set in view>video monitor and I have turned on the window > video monitor, nothing helped so far.
any idea whats the problem?

btw… anytime I quit ardour it crashes.

2046: Did you drag the video monitor from the DMG to /Applications ?
Is there a message in Menu > Window > Log?

on Yosemite or later it may be necessary to first open the video-monitor ( at least once manually (right click > open). it is not a signed application.