Highlife – Open Samples

Hello everybody!
As LinuxSampler didn’t run, I downloaded Highlife from the Distroh homepage (distroh.sourceforge.net). The stand alone program works fine: I can open samples as audio files (.wav or .mp3) or as SFZ or SF2. But after installing the plugin, I found out, that I can’t open any sample files in Ardour.

If I click file>import samples , nothing happens. In the LV2 version, but also as VSTi, no window appears. Is there a way to use Highlife in Ardour?

Highlife LV2

Highlife in Ardour

I try to import samples

File>Import Sample(s)


Nothing happens.

Thank you for your help. I wish you a happy Labor Day!

Kind regards,

Gotta ask the obvious(And honest) question, does it actually work in any other software?


Hello Seablade, thank you for your answer. Yes, it works as stand alone and as LV2 in QTractor. Only Ardour doesn’t show a window.

Just to mention: Are you aware that the linuxsampler plugin works in an unsual way - you need to start a standalone version of qsampler or fantasia to load plugin instruments. The linuxsampler plugin which in the Ardour mixer strip does nearly nothing.

I tried highlife on AVLinux using a recent Ardour3 git build (3.1+GIT3.1-10-ged1f310-avlinux6-1) and qtractor. Highlife worked ok when a single wav file was loaded, semi-worked with a gig file, and basically did not work with sf2 or sfz files in both ardour3 and qtractor.


That information needs to go here: https://github.com/falkTX/DISTRHO/issues?state=open

We are in dire need of a stable SFZ Plugin for Linux, I’ve resorted to using the Cakewalk SFZ Player Windows VST plugin in ArdourVST simply because SFZ use within a DAW using Linux is either extremely cumbersome (Linuxsampler) or flaky (Highlife).

I have reported the issue. Concerning linuxsampler plugin I don’t find it so bad once one understands that you have to start qsampler/fantasia to configure it. Once set up, you do not need qsampler/fantasia again. Well, this is not perfect, but not very hard to deal with. Concerning playing samples I think linuxsampler does a great job.

falktx responded to my bug report about highlife, that the highlife developers have abandoned it. so don’t use it… However it is still on DISTHRO webpage, however which I reported to falktx.

Thank you for all your help – it runs, since I use the vst version from the original discoDSP website (not from the DISTROH site).

Kind regards,

It ran one time, than I wrote, that it ran, but now, Ardour doesn’t load the GUI – it simply freezes. If I load a project with a Highlife track, it shows me an error while loading it: Found a reference to an unknown plugin. I also deleted the highlife.so and copied it again to the lxvst directory, but it didn’t help…

As I started Ardour from the terminal, I got the following messages:
Gtk-Message: Failed to load module “pk-gtk-module”
Gtk-Message: Failed to load module “canberra-gtk-module”

Could that be the problem? It also doesn’t wanna load the GUI of VOPM.

@jano: http://ardour.org/debugging_ardour … those particular error messaages are not an issue.


Highlife from discoDSP uses an older (or somehow different) version of JUCE to display the UI which is notoriously flaky with Linux, IIRC this is why it was recompiled and ‘fixed’ by falkTX, it seems that falkTX was able to improve the GUI performance but there are deeper code problems as you know with the actual sample library loading. It seems like they hit a dead end with Highlife and this is why is was let go into the Open Source world. It was replaced by ‘Discovery’ which also has major UI problems associated with JUCE under Linux. I used to distribute Discovery R3 but it had issues with Ardour and other hosts, I haven’t checked recently if it works any better than Highlife.

Well, Ardour usually freezes when I try to load the GUI of Highlife, so the “thread apply all bt”-command in gdb doesn’t show me anything. That’s what happened in my terminal:
[jano@localhost ~]$ ‘/opt/Ardour-3.1.10-dbg/bin/ardour3’ --debug
GNU gdb (GDB) Fedora (7.5.1-32.fc18)
Copyright © 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later http://gnu.org/licenses/gpl.html
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type “show copying”
and “show warranty” for details.
This GDB was configured as “i686-redhat-linux-gnu”.
For bug reporting instructions, please see:
Reading symbols from /opt/Ardour-3.1.10-dbg/bin/ardour-3.0…done.
(gdb) run
Starting program: /opt/Ardour-3.1.10-dbg/bin/ardour-3.0
[Thread debugging using libthread_db enabled]
Using host libthread_db library “/lib/libthread_db.so.1”.
Missing separate debuginfo for /opt/Ardour-3.1.10-dbg/lib/libssl.so.0.9.8
Missing separate debuginfo for /opt/Ardour-3.1.10-dbg/lib/libcrypto.so.0.9.8
bnd txt domain [gtk2_ardour3] to /opt/Ardour-3.1.10-dbg/share/locale
Ardour3.1 (kompiliert mit Version 3.1-10-ged1f310 und GCC Version4.4.6)
Kann die SIGPIPE Fehlerbehandlung nicht installieren
Gtk-Message: Failed to load module “pk-gtk-module”
Gtk-Message: Failed to load module “canberra-gtk-module”
ardour: [INFO]: lade voreingestellte UI-Konfigurationsdatei /opt/Ardour-3.1.10-dbg/etc/ardour3_ui_default.conf
Lade benutzerdefinierte UI-Konfigurationsdatei /opt/Ardour-3.1.10-dbg/etc/ardour3_ui.conf
ardour: [INFO]: Loading ui configuration file /opt/Ardour-3.1.10-dbg/etc/ardour3_ui_dark.rc
ardour: [INFO]: Ihre Systemkonfiguration beschränkt Ardour auf nur 4096 offene Dateien
[New Thread 0xb4b34b40 (LWP 2213)]
ardour: [INFO]: Lade Systemkonfigurationsdatei /opt/Ardour-3.1.10-dbg/etc/ardour_system.rc
Lade Benutzerkonfiguration /home/jano/.config/ardour3/ardour.rc
Using SSE optimized routines
[New Thread 0xb4333b40 (LWP 2214)]
[New Thread 0xb3b32b40 (LWP 2215)]
[New Thread 0xb3331b40 (LWP 2216)]
[New Thread 0xb29a4c40 (LWP 2217)]
[New Thread 0xad0a9b40 (LWP 2218)]
[New Thread 0xac8a8b40 (LWP 2219)]
[New Thread 0xac0a7b40 (LWP 2220)]
[New Thread 0xac026b40 (LWP 2221)]
[Thread 0xac026b40 (LWP 2221) exited]
[Thread 0xac0a7b40 (LWP 2220) exited]
[Thread 0xac8a8b40 (LWP 2219) exited]
Announcement is:
[Thread 0xb29a4c40 (LWP 2217) exited]
[New Thread 0xac8a8b40 (LWP 2222)]
[Thread 0xac8a8b40 (LWP 2222) exited]
[New Thread 0xac0a7b40 (LWP 2223)]
[New Thread 0xac026b40 (LWP 2224)]
[New Thread 0xa89b8b40 (LWP 2225)]
[New Thread 0xa88b4c40 (LWP 2226)]
[New Thread 0xac8a8b40 (LWP 2227)]
[New Thread 0xa6970b40 (LWP 2228)]
[New Thread 0xa6015b40 (LWP 2229)]
[New Thread 0xa45bab40 (LWP 2230)]
[New Thread 0xa3db9b40 (LWP 2231)]
[Thread 0xad0a9b40 (LWP 2218) exited]
[New Thread 0xad0a9b40 (LWP 2232)]
[New Thread 0xa33c6b40 (LWP 2233)]
[Thread 0xa33c6b40 (LWP 2233) exited]
[New Thread 0xa33c6b40 (LWP 2234)]
[New Thread 0xa273db40 (LWP 2235)]
[Thread 0xad0a9b40 (LWP 2232) exited]
thread apply all bt
[Thread 0xa273db40 (LWP 2235) exited]
[Thread 0xa33c6b40 (LWP 2234) exited]
[Thread 0xa3db9b40 (LWP 2231) exited]
[Thread 0xa6015b40 (LWP 2229) exited]
[Thread 0xa6970b40 (LWP 2228) exited]
[Thread 0xac8a8b40 (LWP 2227) exited]
[Thread 0xa88b4c40 (LWP 2226) exited]
[Thread 0xa89b8b40 (LWP 2225) exited]
[Thread 0xac026b40 (LWP 2224) exited]
[Thread 0xac0a7b40 (LWP 2223) exited]
[Thread 0xb3331b40 (LWP 2216) exited]
[Thread 0xb3b32b40 (LWP 2215) exited]
[Thread 0xb4333b40 (LWP 2214) exited]
[Thread 0xb4b34b40 (LWP 2213) exited]
[Thread 0xb4fca840 (LWP 2209) exited]

Program terminated with signal SIGKILL, Killed.
The program no longer exists.
Missing separate debuginfos, use: debuginfo-install alsa-lib-1.0.26-2.fc18.i686 celt-0.11.1-4.fc18.i686 expat-2.1.0-4.fc18.i686 glibc-2.16-28.fc18.i686 gsm-1.0.13-7.fc18.i686 jack-audio-connection-kit- ladspa-1.13-9.fc18.i686 ladspa-calf-plugins- ladspa-caps-plugins-0.4.2-8.fc18.i686 ladspa-swh-plugins-0.4.15-19.fc18.i686 ladspa-tap-plugins-0.7.0-10.fc18.i686 libICE-1.0.8-2.fc18.i686 libSM-1.2.1-2.fc18.i686 libX11-1.5.0-3.fc18.i686 libXau-1.0.6-4.fc18.i686 libXcursor-1.1.13-2.fc18.i686 libXdamage-1.1.3-4.fc18.i686 libXext-1.3.1-2.fc18.i686 libXfixes-5.0-3.fc18.i686 libXinerama-1.1.2-2.fc18.i686 libXrender-0.9.7-2.fc18.i686 libXxf86vm-1.1.2-2.fc18.i686 libdrm-2.4.42-1.fc18.i686 libgcc-4.7.2-8.fc18.i686 libselinux-2.1.12-7.fc18.i686 libstdc+±4.7.2-8.fc18.i686 libxcb-1.9-1.fc18.i686 lv2-calf-plugins- mesa-libGL-9.1-3.fc18.i686 mesa-libGLU-9.0.0-1.fc18.i686 mesa-libglapi-9.0.1-3.fc18.i686 nss-mdns-0.10-11.fc18.i686 pcre-8.31-4.fc18.i686 rubberband-1.8.1-1.fc18.i686
(gdb) thread apply all bt
(gdb) thread apply all bt
(gdb) thread apply all bt

Thank you for your explanation about the GUI. Do you think, DiscoDSP products will run with Ubuntu (I think, I’m going to install Kubuntu again, I hope that KDE 4.11 has a better stability than 4.8)? In Kubuntu, at least, LinuxSampler would run. But what about other discoDSP instruments? I thought about buying Discovery…

Thank you for your answers!

Kind regards,

Addition to my last post:
Last time I opened a project, the Highlife GUI ran again. Than I opened another project, an it no longer ran.


@jano: almost certainly JACK killed ardour because it was too slow. As mentioned on the debugging page, when running ardour inside gdb, you need to run JACK in non-realtime mode and with a long client timeout.

I’m sorry, I hadn’t access to the internet any more as I canceled my contract for the SIM card flatrate with BASE (I had to use a SIM USB stick to go online). There where a few problems with the DSL connection with O2, and at the Internet café they hadn’t got Ardour installed ;). But now, I have got a DSL connection.

I have installed Kubuntu now, and I installed Ardour from the repository. If I run “ardour3 --debug”, it says that the option “–debug” needs an argument ("/usr/lib/ardour3/ardour-3.2: Die Option »–debug« erfordert ein Argument"). If I run “gdb ardour3”, ist says:

“/usr/bin/ardour3”: not in executable format

I turned off realtime in Jack. Any idea?

jano: I do not support distribution builds of Ardour.