Hiccups and DSP usage

Ardour 5.12 on Fedora 29 using Zoom R24 as sound card.

While working on a mixing project it suddenly started to produce ‘hiccups’ (short dropouts) during playback of anything. Also, the DSP indicator indicates continuous activity, often in the red, even when Ardour is doing nothing (not recording, not playing). I use a-EQ and Dragonfly reverb plugins only.
The hiccups can also be heard when using the system sound card so it is not R24.
When I revisit some earlier projects they play flawlessly.

So I must accidentally have done something in this project… But what?

That explains the dropouts.

Seems like some plugin are requiring a lot of CPU and increase the DSP load.
You might be able to mitigate the issue by increasing the buffer-size. Menu > Window >Audio/MIDI Setup.

Likely those other sessions use different plugins and may also have different amount of tracks?

Perhaps try to disable some plugins or deactivate some tracks (track-header context menu), also make sure to check hidden tracks (if any). If a single plugin is causing this, you should be able to track it down this way.

Just because you are not recording or playing doesn’t necessarily mean you are not processing. DSP by default is processing audio all the time, so when not doing anything it is processing silence. So especially depending on how many instances of Reverb you are talking about in that session, it could be a simple issue of not enough DSP.

Yep what @x42 said.


I disabled all six reverbs (put on bypass) and playback is undisturbed. Enabled all reverbs one by one and playback stays undisturbed, with DSP values between 5-25%. Good.

Then I restarted Ardour and the hiccups are back, with DSP 90-100%…

BTW, may I assume that tracks that are disabled (not visible, not active) do not contribute to DSP activity?

BTW2, I tried to reproduce with stock ardour but it runs no more on Fedora 29 due to fontconfig incompatibilities. (I thinks it is related to https://github.com/synfig/synfig/issues/682)

Also, do I need a more powerful DSP?

Same issue when you bypass all reverb plugins, save session and reload?

Reverbs often cause issue because of denormals. Check Edit > Preferences > Audio > Denormals. What is the setting? Does enabling “use DC bias” help at all?

@paul: No DC bias, and use FlushToZero and DenormalsAreZero. Enabling DC bias does not make a difference.

@x42: I can save/restart with up to 5 reverbs active, and then enable the rest and still have good playback. Restarting with all six brings back the hiccups.

Visibility plays no part in this. if you hide them they still process audio.

Only deactivating tracks does disable processing.

I read an article on the net:

The average good computer nowadays might have a six-core CPU. It’ll run everything very easily, and software can use multithreading. Is external DSP processing still necessary these days?

“Absolutely not. Not even for tracking. On the Mac that I’m speaking to you on, I just loaded a 120-track session from a friend of mine, with all these vocals and all this crap. I put a bunch of plugins on it, reverb all over the place. I couldn’t even break 50% CPU if I tried.

My ardour session had 10 active tracks, 6 with reverb. I consider my PC ‘rather powerful’ (Intel Core i7-8700 CPU @ 3.20GHz, 32GB memory) – so I doubt the system is the bottleneck. It must be some interaction between instances of the Dragonfly reverb plugins.

Do all six reverb plugins have different settings? Typically reverb plugins are put on a bus, and you have one or maybe two per project. Add sends from each track to the reverb bus, set reverb to 100% wet, mix reverb bus into overall mix. Six reverbs on one project would be really unusual.

Yes, that’s what I usually do after some experimenting with the sounds. (Albeit that I route the tracks only to the bus, and set wet/dry in the reverb plugin.)

I just hadn’t gotten that far so I did have six tracks with reverbs.

Still this feels like workarounds, not solutions.