Help with Send MIDI Clock

(Simply Jonas) #1

Hi, I am a bit new to the Ardour MIDI functions.

My problem is can’t seem to get Ardour to send Midi Clock to my USB Arturia Keystep.

I want to sync the Arpeggiator on the KeyStep to the clock in Ardour so that when I press record the Keystep will be in sync. Thus when I record audio from an external synth connected to the keystep’s MIDI out, the arpeggation will sync with the beat of the other tracks.

I have set the keystep to receive clock via USB. And I have also enabled MClk Generator in the Preferences menu.

I have also tried to add an extra MIDI track and messed around with the MIDI routing grids on both inputs and outputs on the track, with the keystep assigned, to no effect.

I have tried to read the manual. (It says someting about sending to a JACK-port. I am not using JACK at all and the manual also says clearly that JACK is not needed since v 4.0 and I am using the latest version.

What am I missing?

(Admin) #2

Ok, sorted it.

Novation Supernova II multitimbral setup In Ardour 5.12.0 on 64 Bit Ubuntu 16.04 LTS

Ignore the Global Channel stuff in the Novation Sequencer setup doc, you don’t need it. Set up 8 tracks in Ardour, use Midi Channel Map plugin by Robin Gareus: http://x42-plugins.com/x42/ to direct output to each of the seven tracks (the first one doesn’t need this as it’s already on Channel One) directing channel one on each track to the respective 02 - 08.

Set the Global Midi Channel to 09 and make sure the Midi Clock is set to External on the Novation as per the other Novation doc.

Edit > Preferences > Sync > MIDI > Enable Mclk Generator in Ardour.

In Midi Connection Manager, Window > MIDI Connections, set Midi Clock OUT (the port is inside/under the “Ardour Misc.” tab of the MIDI connections window) to the MIDI OUT of the MIDI device you are using. In my case it’s listed as ESI M8UXL MIDI 1 (Out) as my hardware is connected that way.

One last thing, I had to perform a full factory reset on the Novation, and a ROM restore before any of this worked. The bit that really got me was Midi Clock Out to MIDI 1 Out.

Oh yes, save the damn thing as a template.

(Paul Davis) #3

I can’t really offer offer than what mhartzel offered above, describing his use of MIDI clock with an SR18. There is a single MIDI Clock output port. If “send MIDI Clock” is enabled, then MIDI clock will be delivered to that port. Have you connected a MIDI monitor app to check it is being sent? I don’t know what platform you’re on so I can’t suggest one.

(Paul Davis) #4

Edit > Preferences > Sync > MIDI > Enable Mclk Generator

There is an outbound and inbound MIDI port for MIDI clock. You need to connect to the appropriate other port (e.g. whatever hardware port your Arturia shows up as). You can do this in Window > MIDI Connections

(Paul Davis) #5

The port is inside/under the “Ardour Misc.” tab of the MIDI connections window.

(Simply Jonas) #6

Hi Paul,

Thanks, that was indeed the issue.
It kind of works now, but it de-syncs after a while. Noticeable after ~30secs. If I press stop-start on the keystep it syncs again. Not sure how to fix that. Seems wierd since it should in theory stay in sync since it receives the clock signal continuously. The red light on the keystep flashes in sync when “play” in Ardour is pressed, it keeps flashing until i hit “Stop” in Ardour, only it goes out of sync after a little while. Enough that it is not useable like this.
Any ideas what might be the issue would be greatly appreciated :slight_smile:

Thanks again

(Mikael Hartzell) #7

I’m not sure what exactly causes your problem, but I use a drum machine (Alesis SR18) synced to midi clock generated by Ardour. When I press play on Ardour the drum machine starts to play and when I stop Ardour then the drum machine also stops but exactly at the point of the drum sequence where I pressed stop. The next time I start Ardour the drum machine starts to play but not from the beginning of the drum sequence but from the point where I last stopped it. Pressing the “Stop” button on the drum machine before starting playback resets the play position in the drum sequence to its starting point. Maybe this has something to do with your problem also ?

The manual of your device says: “When the external source is not running, KeyStep will function according to its internal clock at the last known tempo”. Maybe this causes the arpeggiation sync point to move in time when you press start / stop repetedly ?

(Admin) #8

I have tried and tried and tried, but whatever I do - I cannot get Midi clock IN to any track. I can see it going out, I have connected the correct track, but nothing appears in the MIDI Tracer window for MIDI clock in. It’s almost like there is a filter on outbound MIDI clock. I followed the instructions above and … nothing any pointers?

(Admin) #9

I am using Ardour 5.12.0 64 Bit Ubuntu 16.04 LTS

(Paul Davis) #10

It is really unclear what you’re doing … you talk about MIDI Clock in and MIDI Clock out as if they are the same thing. You don’t send MIDI clock to a track.

(Admin) #11

Ok that helps!

I was working from this doc: https://support.novationmusic.com/hc/en-gb/articles/206865929-My-Nova-Nova-II-arpeggiator-does-not-run-
and this doc here: https://d2xhy469pqj8rc.cloudfront.net/sites/default/files/novation/downloads/4093/supernova2sequencer3.pdf

Obviously the instructions need to be tweaked for Ardour it’s that bit I don’t understand.

My terminology was off. PORT not TRACK.

I want to get the MIDI CLCK data into the arpeggiator on a Supernova II MIDI channel 9

Many thanks as always for the support.

(Admin) #12

Ok, slight edit, I put the Midi Channel Map on track 01 as well, turning off all other channels as it started to confuse the hell out of the Novation.

(Paul Davis) #13

What parts of this were not obvious to you at the beginning?

(Admin) #14

Midi Clock Out to MIDI 1 Out seemed counter-intuitive, the fact that the Novation was then receiving MIDI Clock and not responding correctly before the total reset, and the red herring of the Global Track in the Novation doc. Previously I had also expected the Midi Channel Selector to parse input as well as output from disk before confirming that it is output only - hence the requirement of the plugin.