Help mapping Akai MPK mini faders etc. to ardour

Generic MIDI selected

The “learn” function ( ctrl+middle mouse button) is not working for me.

Am I ( as usual ) missing something?

Help much appreciated!

Thanks in advance!


1 Like

No message.

Could my Mac keyboard be not sending the same “alt” message as a pc keyboard, ?I will try to find a working standard kbd…

Thanks again for taking the time to try to help me, I really do appreciate it !


Not Alt+MMB it’s Ctrl+MMB

Oops , typed wrong key, I have been using CTRL as I should have been, also tried ALT, Command, and Fn keys.



Not Alt+MMB it’s Ctrl+MMB

Not sure if the mac keybd could be an issue…

Are you using qjackctl to manage jackd and MIDI connections? In qjackctl you should have your MIDI devices listed under a tab called MIDI or ALSA where you can connect them to Ardour.

@wirehead: did you also turn on Generic MIDI Control in the Options -> Surfaces menu? MIDI Learn does not work without it.

Options -> Surfaces menu Generic MIDI Control selected

Qjackctl Midi driver set to “seq” ( also tried raw " )
Connections in MIDI and Alsa tabs tried in many configurations ( somewhat randomly since I have no clue… )

Middle mouse button works in other programs. Logitec ball mouse.

PCLinuxOS2010 and Ardour2 in case it matters.

I have very little experience with MIDI so it could be something obvious I am overlooking in making connections in qjackctl or something overlooked in another area that I have not even found yet?

Thanks for your time !


When hitting Ctrl+MMB (Middle Mouse Button) do you get a message asking you to operate your device controller?

If you do then it for sure is an issue with your MIDI connections in qjackctl, also double check your real MIDI cables to see you are routing everything right.

Standard keyboard still no go.

Hmmmm, I’m thinking this might be a similar issue I had (or still have) with Ardour2. In order to save MIDI map for my M-Audio Oxygen8V2 I had to create a template and have to always load it when starting out a new session.

See if any of these posts help a bit…

Also what version of Ardour2 are you using? Is it self compiled or from some repository?

Audacity2 from PCLinuxOS2010 repository.

Thanks for the links, I will give them a look!

Audacity??? or you mean Ardour

Yeah Ardour I have to not post so late at night…

Sorry, I am not really as much of an idiot as my posts seem to indicate, really, I think…

Thanks for even responding !

Thanks again for the help!


Well don’t be so hard on yourself.

If you get to figure it out just post your results so people can see how to do it. Also maybe someone will jump in later with the answer you are seeking, so just keep your fingers crossed…