Harrison plugins bundled with Ardour

Has anyone else tried using the Harrison Mixbus Plugins that come bundled in Ardour? I have licenses for them and tried to run the Gverb+ and a few others and have run into consistent crashes inside Ardour. Perhaps these are older versions of the plugins?

This is on Unbuntu 16.04 with Ardour 5.5.

I use Debian Jessie 64bit and had the same problem (bundled Harrison plugins crashing Ardour). This fixed it for me:

  1. Delete Harrison plugins from Ardour directory in /opt;
  2. Move Harrison plugins from Harrison folder in /opt to /usr/lib/lv2

Now Ardour loads and uses Mixbus plugins without issue as does Mixbus, which still finds it’s plugins in /usr/lib/lv2


I use a few of them regularly, GVerb, 3D Triple Delay, XT-BC, XT-DC on (AV Linux based on Debian Stretch) and they are quite stable for me. I’m also using Ardour 5.5 from ardour.org. As a side not I do most of my production on 32bit still.

Thanks dawiba that worked. No more crashes once I move the Mixbus plugs so Ardour could see them and deleted Ardour-bundled ones. Probably should file an issue report.

Got also crashes with Harrison plugins inside Ardour 5.5. They crash immediately after adding them to a track. I’m on Debian 8 64bit too. Will give the workaround a try.

I can confirm that copying the files from the Ardour or Mixbus lib folder to /usr/lib/lv2 does work.

1 Like

@ohzbees and dawiba
What graphic card do you use in your computer? Intel onboard HDxxxx?

Looks like Intel Q35:

Do you move everything from /opt/Ardour-5.*/lib/LV2/ (including the lv2core.lv2 dir) or only the Harrison XT- plugins?

it seems that it’s GUI related so Preferences > Plugins > Automatically open GUI… would probably allow to add them.

I opened several of these Ardour-bundled (and later authorized) Harrison plugins in audio tracks and they worked fine but they crash when I try to use them on a midi track (to process audio output). I’ll try some of the suggestions here.

@ swindus: Intel onboard
@x42: from memory, only the Harrison plugins

I experimented by moving one Harrison plugin – the 10 band EQ – from the Ardour lib lv2 folder to the usr lib lv2 folder. I didn’t move the lv2core.lv2 folder or any other plugins. This time, I could open the EQ plugin in a midi track and it worked. However, on closing and reopening Ardour, I get a crash if the plugins are enabled. With all plugins turned off before closing Ardour, the EQ works on both a midi and audio track, upon reopening and re-enabling. I tried playing around with the preferences such as Preferences > Plugins > Automatically open GUI… but it seemed to hurt more than help so I returned them to their default settings. I’m on Ubuntu Studio 16.04, Ardour 5.5 and generally haven’t had any plugin issues. The Calfs seem to get a bad rap and I do get the occasional crash so I am exploring alternatives. Not sure about the Harrison yet.

I’ve concluded that the only way I can use these plugins (in their present state) is to add them to an audio track, record something in a one-off session, and import the recording to a session that doesn’t have any Harrison plugins loaded. They are just too crash-prone to include in any session with plugins that don’t crash. Sadly, I bought a couple of licenses.