Harrison Mixbus is now available for Linux and OS X

Great :slight_smile:

Do the mute buttons work with mixbus? They never really worked with buses and lately don’t work at all, at least not in my version (2.8.11 built from revision 8444). I don’t expect perfection but this has been quite awkward and could be another reason to try mixbus if it solves the problem.


Right click on them and make certain all the boxes are checked. Chances are you are being bitten by a settings problem from an old bug that was fixed some time ago and moving your ~/.ardour2 folder out of the way to let it be regenerated means that new sessions will probably work correctly.

Though to answer your question, yes obviously they work in Mixbus as well.


Thanks just tried that - still stuck with no mutes. This probably isn’t the place to discuss it though and I’m on Gentoo which AFAIK you don’t support. Thanks for the tip though :slight_smile:

@mcgruff: just tried what? its true that we don’t support gentoo builds because of their use of SYSLIBS, but this mute thing was a serious bug in Ardour that has been fixed. there is no reason for you to still be suffering from it. What did you try?

I tried deleting ~/.ardour2 but didn’t check the right-click menus on the mutes. They used to work so I just assumed they were still OK. They weren’t, but fixed now :slight_smile:

Thanks everyone for your help.

Someone may want to update the landing page of this site from “Now available! Mixbus® : Ardour + Harrison DSP for OS X” to reflect this great news.

@tgoose: done - thanks for the suggestion/reminder.

This is great news… I wonder if the plan is to update mixbus to ardour 3 when it comes out?

I want to use mixbus for sure… but I’ll probably end up needing to ditch it if it isn’t compatible with ardour 3 sessions in the near future.

Any insight to future dev plans for mixbus?

Eventually yes, immediately after A3 is released, probably not so much.

Spoken by someone that has no affiliation with Harrison Consoles mind you, but I am fairly confident in that.


Yes that is what I meant.
I did not know that its possible to run Mixbus as an external Mixer.
Mixbus starts with me within ardour2

Mixbus is a program in itself. It is based on Ardour2, it does not start within Ardour2 or Ardour3, but rather contains the functionality from Ardour2 as that is what is based on.

What some people have been doing is using just the mix functionality of Mixbus, by routing other programs into busses(Or tracks if they record the output) in Mixbus and those into the mixbusses, to the master, etc. and then recording the output of the master either within Mixbus or in whatever program they start in. It is taking advantage of the mixing in Mixbus, but using whatever program t hey want for editing.

Now that being said, if you are starting from Ardour2, I see only very particular cases this is a benefit(You want to keep your mix information separate from your edit information for some reason, say to apply it across many edited sessions). Other than that you may as well just use Mixbus as the editing features are pretty close to identical to Ardour2.

If you are starting from Ardour 3 it will depend on what exactly you are using in A3 as to whether you wish to do this or not. As A3 isn’t even released yet(Or in any form of public testing) I would figure that most people would not want to do this yet at least.


I was asking this because Ardour 3 supports midi.

Yes I understand that, but it is not at a point where it would be stable to use for production work.


yeah you’re right there I was just wondering for the future
Anyhow ardour2 and mixbus is a strong formula

When I installed Mixbus, I got this message:

"System failed the quick sanity check…Looking for the cause

!!! WARNING !!! - Your system seems to use frequency scaling.
This can have a serious impact on audio latency. You have two choices:
(1) turn it off, e.g. by chosing the ‘performance’ governor.
(2) Use the HPET clocksource by passing “-c h” to JACK
(this second option only works on relatively recent computers)"

Anyone else get this message?

Yes other people get it, what is your question exactly?


@Worker Ant: Its telling you that the machine you are installing the software on is set to use a variable CPU clock speed (probably on a portable machine, as part of the power management scheme) Mixbus will still install and run, but if you want to get the best and most reliable performance you might want to follow the suggestions in 1) and 2)

I got the same message on a 64 bits system no portable machine.
Modern CPUs and the kernel’s CPUFreq implementation are able to switch frequencies very fast.

They can switch fast, but not fast enough to upset the behaviour of programs that have a very tight coupling to what is assumed to be constant-rate h/w. It might not cause a glitch in JACK in many cases, but its still not right the way to run a machine designed to do pro-audio.

Maybe the best thing then is to turn off power management - performance because most things are done dynamically these days.
I know openSuse has chosen to remove those CPU frequency settings from the GUI.
Advanced users still can make use of command line tools like the cpufreq-utils.