Harrison AVA plugins

Is anyone having problems with plugins offered by Harrison Audio (https://www.harrisonaudio.com/], not Harrison Consoles? I have three plugins that don’t work: Legacy EQ (free), Mastering EQ (the free new one; I have the version from Harrison Consoles which works fine), and the Harrison Audio microglide $20USD). My problem with the plugins is that they open okay, but the GUI does not work. It is unresponsive and will eventually freeze. I can use the inline controls; however, they are very finicky and imprecise.

I tried one of the plugins (legacy EQ)on three different computers running Ubuntu Studio 22.04, and one running Ubuntu Studio 23.10 (with the latest kernel). I also tried it on AV Linus, Fedora Jam, and Manjaro with Ardour installed. It did not work on any of them.

I’m mostly concerned about the next Mixbus upgrade. If the plugins don’t work, will the DAW?

I asked Harrison, and was told that I needed OpenGL V3.2 or later. I did check and found that I have the correct version (I have 3.2 or later). From what I can see, curl does have gnutls support.

If you had problems with the plugins or the AVA plugins in general, how did you resolve it?

One and the same company.

I would bet an issue with OpenGL then as their guis are written in OpenGL IIRC.

Sadly I haven’t run them on Linux in a while myself to really comment.


AV Linux comes with all of the Harrison stuff pre-installed, are you saying the pre-installed AVA and 32C ones didn’t work? The current AV Linux ISO is a bit over a year old so the AVA versions on there should have worked…

EDIT: Seems to be working here on this particular machine with AV Linux 21.3:

And the plugins even work with the Mixbus32C-9 on AV MX Linux.

This is likely a video driver / OpenGL setup problem. I had a similar issue a few years ago on Ubunutu LTS.

Give this a whirl, there are instructions to reverse if it does not work.

The issue is not with the legacy AVA plugins - those seem to work fine. The problem is with the plugins that are available from Harrison Audio (formed from Harrison Consoles and SSL); on both Mixbus and Ardour, Harrison Consoles and Harrison Audio show up as different creators. If the plugins from Harrison Audio (that use iLok for Mac and Windows) won’t work on linux, I just will stick with other linux plugins. However, if I can get the Harrison Audio plugins to work, I’ll be able to take advantage of any new Harrison plugins that are developed.

I’ll install the Mesa drivers, and see if that works.

I have install the Harrison Audio version of AVA Multiband Compressor on Ubuntu 22.04 LTS and can confirm that the GUI is working just fine on my system. RTA scroll and lighting work as expected.

CTRL with the mouse to allow fine tuning on the sliders if you decide to use it that way. Hopefully that MESA update will do the trick.

On the Linux Musician forum, it was suggested to add ‘env v_blank_mode=0’ before opening the app, when starting the app from the line command. I tested it for one of the plugins, and it worked. I did not test the other Harrison plugins, or any of the other linux plugins. However, this seems to be a solution.


i have the same issue as you. are you by any chance using an nvidia graphics card? Harrison always tries to blame nvidia cards for this issue.
I opened a support ticket per @seablade 's suggestion. I got a reply with the usual answers. To run the program with a command that forces the system to report an opengl version of 3.2 or higher. I was already doing that but went ahead with his instructions so that they can go through their diagnostic procedure.
The same behavior exhibited itself again, so I documented and replied to support, but I didn’t head back. I gave them another reply with more evidence of the behavior, and still no reply.
I just send them another email reminding them that I’ve spent a lot of money of Harrison products the last couple years. My guess is they won’t reply and I’ll have proven myself a fool for supporting a company product instead of donating more money to a respectable product like Ardour.
ANYWAYS… is the “env v_blank_mode=0” command still working for you? Also, when AVA GUIs stopped working, would you also experience the DAW hanging when you attempt to quit? And to be specific, are you also using Harrison’s Mixbus or are you using the AVA plugins in Ardour?

It’s not NVidia cards that are the issue. It’s the version of the video driver and its OpenGL compliance.

1 Like

Appreciate the reply, as always, Paul. Would you know which video driver and versions are the problematic ones? Bc I’ve used 2 different proprietary drivers from the ubuntu repos and the newest version of the nouveau driver and none of them make a difference with this [not ardour] problem. having the system report opengl version 3.2 also does nothing for me.

What version of linux are you using ? I had to upgrade my Mesa OpenGL drivers from a seperate repository to get these to work on Ubuntu 22.04 LTS.

Intel Chipset graphics on my system though.

1 Like

I’m on Xubuntu 20.04.6 LTS with linux kernel version 5.15.0-91-lowlatency and the Ubuntu Studio package installed.
What repos did you have to add?

This link should help

I installed obiaff ppa, but they are updated twice each day. That is too many updates.

I would go with the kisak-mesa ppa next time. I would suggest you should use kisak.

1 Like

appreciate it comrade. i started googling my specific graphics card and gl version and i came across a thread i haven’t before. that thread concludes with adding the user to the video group. im going to try that tonight, if it doesn’t work, im going to try the solution @Duke_Of_Sound proposed since he disappeared after saying it was working. if those dont work, then ill add the kisak-mesa repo and hope that finally does the trick.
side note: i love this forum and all of you here. harrison forums are always dead and kind of pretentious.

@drsaamah Sorry I’ve been AWOL. I’ve been working on other projects. It answer to your questions above:

  • Yes, adding ‘env v_blank_mode=0’ before opening the app from the command line does still work;
  • I tested it on both Ardour and Mixbus, and it worked for both.
  • Now that you mention it, when the plugin crashed I did have problems closing Mixbus/Ardour. I may even have had to resort to forcing them to close.

That’s and interesting idea adding the user to the video group. I’ll give that a try.

1 Like

Thanks for the reply!
I think your solution is the right one. Adding myself to the video group didn’t do anything.
But setting the environmental variable to mentioned to zero seems to work. I had a mix session yesterday with quite a few AVA plugins. No gtk errors printed to the terminal and, more importantly, no AVA GUI crashes/glitches.
Thank goodness, bc Harrison support finally replied to tell me they can’t help me :roll_eyes:

I’m glad that it worked for you. I had the same problem with Harrison support. At least there is a reasonable answer without having to buy a Mac or Windows computer (I’m using Ubuntu Studio).

1 Like

Yeah I think all of us that are having this problem have some flavor of Ubuntu. Something about Ubuntu is the problem (or maybe Debian?).
What’s interesting is when I launched using your solution, I didn’t even bother setting the mesa opengl version above the 1.4 that it keeps defaulting to. So whether or not opengl version is >3.2 doesn’t even seem to matter.
Re: @paul 's comment earlier and my ignorant follow-up question… I now understand. And it is not the graphics card driver that is a problem here. My card and its driver support opengl 4.6 and glxinfo shows as much. Why it keeps reporting 1.4 is beyond me, but again, not actually the heart of the issue here.

@drsaamah I actually tried the plugins with Mixbus running on Fedora Jam, and on Manjaro. The plugins would not open in either of these distros, though I can’t remember the error message. I think that some lib file was missing.

1 Like