Hardware Setup

Recording Gods:

I am lost. I’ve read so many manuals and tried so many things. Much learned about Ardour but I cannot get anything to work how I want:

I can record by running JACK with default settings and using Ardour default. But only with the built in Mic in my lap top. I have the newest M-Audio Mobile Pre USB. I took a screen shot of every connection window I can find:

http://thesearchparty.org/matthew/ALSA.png</a href>

http://thesearchparty.org/matthew/Audio.png</a href>

http://thesearchparty.org/matthew/ardourTab.png</a href>

http://thesearchparty.org/matthew/system.png</a href>

</a href>

Please help me. To stop recording with my lap top mic and have Ardour 2.3 listen to my guitar through the cable.

God ? … :slight_smile:

well, I have on my feeling that you have two soundcards (hw:0 and hw:1) and that Jack picks by default hw:0 which happends to be the onboard chip.

so to be sure, do the following in a bash shell :

ls /proc/asound

show us what it spits out

then :

aplay -L

same again.

Then, if your USB device is hw:1, make sure that qjackctl picks this one in the setup (I think it’s called Interface in the setup screen).

Hope this helps :slight_smile:

Thanks for helping. Here is the shot of what you asked for

http://thesearchparty.org/matthew/aplay_-L.png</h ref>

the options under interface are


you will have to enter hw:1 by hand in Interface since it is clear from your screenshot that qjackctl picks your onboard chip instead of your USB device. And if you don’t need the onboard chip, think about disabling it in your BIOS.

In a shell, type

cat /proc/interrupts

and see if you USB device is sharing interrupt with it or another device. It is a good idea that your audio device has its own interrupt without sharing it. SO, if you do disable the onboard chip in the bios, your USB device will become hw:0 and in this case, there would be no need to change anything in qjackctl. BUt anyway, try to enter hw:1 by hand and see what happens.

I think you are onto something here:

muddlefoot@honkermuddlefoot:~$ cat /proc/interrupts
0: 365614 XT-PIC-XT timer
1: 1861 XT-PIC-XT i8042
2: 0 XT-PIC-XT cascade
4: 4 XT-PIC-XT
5: 1 XT-PIC-XT
6: 5 XT-PIC-XT floppy
7: 0 XT-PIC-XT parport0
8: 3 XT-PIC-XT rtc
9: 1133 XT-PIC-XT acpi
10: 1 XT-PIC-XT
11: 7913 XT-PIC-XT uhci_hcd:usb1, uhci_hcd:usb2, uhci_hcd:usb3, ehci_hcd:usb4, yenta, eth1, Intel 82801DB-ICH4, i915@pci:0000:00:02.0
12: 73965 XT-PIC-XT i8042
14: 19373 XT-PIC-XT libata
15: 12700 XT-PIC-XT libata
NMI: 0 Non-maskable interrupts
LOC: 0 Local timer interrupts
RES: 0 Rescheduling interrupts
CAL: 0 function call interrupts
TLB: 0 TLB shootdowns
TRM: 0 Thermal event interrupts
SPU: 0 Spurious interrupts
ERR: 0
MIS: 0

I feel like a goober; there is a arrow next to the drop down box on the settings tab of the setup box. Under that hw:1 is an option and it says Mobile Pre right next to it. Do you know what the drop down box options offer? I listed them in a previous post


I am madly in love with you. It worked! I do hear some crackles? Does that have to do with all them crazy numbers on the setup window? How can I figure out what numbers to plug in? Is it just a change it and see kind of thing?

Again. I love you.

Hey! I am not asking for so much :D:D
About the crackle, you use a USB device so it would be wise to set the periods/buffer to 3 in qjackctl :slight_smile:
Another thing, I can see that you are using a non-apic system. What are the h/w specs of your system (just curious) ?

Now, for the drop down menu, it looks like alsa’s standard naming (hw is direct hardware, plughw is a plugin abstraction - if that makes any sense - /dev/dsp is good ol’OSS and (default) is whatever is the default in your $HOME/.asoundrc).

Thanks for the periods/buffer tip. My system is a Thinkpad R51 (older) 1.4 Pent M chip 1 GB RAM 100GB HD 5400

What else do you wanna know? Right now I am testing out my 5.5 gen Ipod as my drive for recording onto. Is that a good idea? Do you want to get married? I’ve really never believed in marriage and love. But this thread is changing my beliefs.