Gverb / Ardour Bug?

I’ve written about the crazygoing plugins - now I have a repoduceable situation where the Gverb Plugin goes crazy:

I loop a situation to listen to the beginning of a recorded song - the loop begins just half a second before the guitar starts the song. When the loop jumps back to this start, the Gverb plugin in the post section of the vocals gives a crashing noise which is about +30 db in the red. My ears still hurt, and I was just listening to the song in an average volume. I did not see anything worse in any other program before…

The crashing noise is not there if I deactivate the plugin.

Is this problem fixed in 0.99.3? I’m not that a linux freak a have a lot of probs compiling 0.99.3. I still use 0.99.2 in debian unstable. the plugins are up to date.


I had a similar issue where the plugins would peg the meters at the end of a loop right before it went back to the start of the loop. The issue went away when i changed my ‘sync’ to ‘internal’ instead of ‘jack’.

The sync option is in windows->options->Sync

I hope this helps…


It’s not the sync - my ardour is already sinced internally, I also tried the other way sincing it with jack, but there’s no change.

I started a second ardour and recorded THE NOISE… If anyone wants a party killer (I should get the copyright on that, hehe), send me a note…

I put the fast lookahead limiter in the insert of the channel with the recorded file - I cannot give you the file as it is, because it blows out everything. I really really hope my monitors aren’t hurted yet. The limiter showed me an about 40-50 db decrease of THE NOISE so imagine how the file sounds in orignal…

So you here you hear my loop (twice): The first crashing noise is with Gverb activated (at 17s), the click/pop coming after is without the Gverb avtivated (at 35s, the limiter decreased the volume about 20-25 db).



I also recognised that ardour (or the plugins) clicks and pops if I loop nothing, i.e. an area where no sound file is placed.
Is this the “Fixed silence issue with inserts” change in ardour 0.99.3?

Thanks for reading,

I’m unable to duplicate the issue in 0.99.3. I suggest you try to get 0.99.3 compiled.

Have you followed the instructions on http://ardour.org/building when you tried building 0.99.3 yourself? You need not only the libraries themselves, but also the -dev packages. Without the -dev packages, you will not be able to compile ardour (or anything else which uses those libraries for that matter).

I compiled succesfully (I already installed the -dev packages, I am aware of this, but the problem was with pkg-config - I had to change the PKG_CONFIG_PATH for some reason). The noise is still there. It’s not at all that loud than before, and the sound is more like my C64 :), but it’s still there.

Before you think too deep; my ardour 0.99.3 looks not very nice… Nearly no colors, sometimes thins aren’t readably from screen and most of the time I can’t see the waveforms… did it build correctly? It gave me no error during the compiling (Maybe I can give you a screenshot when I found out how to do that with enlightenment).


Did you compile & install ardour “on top” of the previous version? (i.e. you didn’t uninstall the previous one)

Also, did you give scons the parameter PREFIX=/usr ?

You should only keep one version of ardour installed (normally in /usr) if you don’t know exactly what you’re doing. Remove the old one, rebuild with PREFIX=/usr and install again.