Gui missing (Ubuntu 22.04)

Hi all,

I recently installed Ubuntu 22.04.1 64-bit.

After installing Ardour 7.1 from Synaptic (adding the Ubuntu Studio ppa), I don’t see the usual plugin gui at the top left (and also the gui at the bottom left).

So I removed the ppa and I installed Ardour 6.9.0 (again from Synaptic), but the problem remains, the gui on the left is missing:

Ardour version:
Ardour 6.9.0~ds0
“After Bach”
(rev 6.9.0~ds0-1build1)
Intel 64-bit

This is the configuration:

Build documentation: False
Debuggable build: False
Export all symbols (backtrace): False
Install prefix: /usr
Strict compiler flags: []
Internal Shared Libraries: True
Use External Libraries: True
Library exports hidden: True
Free/Demo copy: False

ALSA DBus Reservation: True
Architecture flags: None
ARM NEON support: False
Aubio: True
AudioUnits: False
Build target: x86_64
Canvas Test UI: False
Beatbox test app: False
CoreAudio: False
CoreAudio 10.5 compat: False
Debug RT allocations: False
Debug Symbols: False
Denormal exceptions: False
Dr. Mingw: False
FLAC: True
FPU optimization: True
FPU AVX/FMA support: True
Freedesktop files: True
Libjack linking: link
Libjack metadata: True
Lua Binding Doc: False
Lua Commandline Tool: True
LV2 UI embedding: True
LV2 support: True
LV2 extensions: True
LXVST support: True
Mac VST support: False
NI-Maschine: False
OGG: True
Phone home: False
Process thread timing: False
Program name: Ardour
Samplerate: True
PT format: True
PTW32 Semaphore: False
Threaded WaveViews: True
Translation: True
Unit tests: False
Use LLD linker: False
VST3 support: True
Windows VST support: False
Wiimote support: True
Windows key: Mod4><Super

PortAudio Backend: False
CoreAudio/Midi Backend: False
ALSA Backend: True
Dummy backend: True
JACK Backend: True
Pulseaudio Backend: True

Buildstack: -system-
Mac i386 Architecture: False
Mac ppc Architecture: False
Mac arm64 Architecture: False

C compiler flags: ['-I<<ARDOURSRCDIR>>', '-g', '-O2', '-ffile-prefix-map=<<ARDOURSRCDIR>>=.', '-flto=auto', '-ffat-lto-objects', '-fstack-protector-strong', '-Wformat', '-Werror=format-security', '-DHAVE_RF64_RIFF', '-DWAF_BUILD', '-DNDEBUG', '-fshow-column', '-O3', '-fomit-frame-pointer', '-ffast-math', '-fstrength-reduce', '-pipe', '-DARCH_X86', '-mmmx', '-msse', '-mfpmath=sse', '-DUSE_XMMINTRIN', '-DBUILD_SSE_OPTIMIZATIONS', '-DLXVST_64BIT', '-Wall', '-Wpointer-arith', '-Wcast-qual', '-Wcast-align', '-Wno-unused-parameter', '-DBOOST_SYSTEM_NO_DEPRECATED', '-D_ISOC9X_SOURCE', '-D_LARGEFILE64_SOURCE', '-D_FILE_OFFSET_BITS=64', '-DPROGRAM_NAME="Ardour"', '-DPROGRAM_VERSION="6"', '-Wstrict-prototypes', '-Wmissing-prototypes']
C++ compiler flags: ['-I<<ARDOURSRCDIR>>', '-g', '-O2', '-ffile-prefix-map=<<ARDOURSRCDIR>>=.', '-flto=auto', '-ffat-lto-objects', '-fstack-protector-strong', '-Wformat', '-Werror=format-security', '-I/usr/include/qm-dsp', '-DHAVE_RF64_RIFF', '-DWAF_BUILD', '-DNDEBUG', '-fshow-column', '-O3', '-fomit-frame-pointer', '-ffast-math', '-fstrength-reduce', '-pipe', '-DARCH_X86', '-mmmx', '-msse', '-mfpmath=sse', '-DUSE_XMMINTRIN', '-DBUILD_SSE_OPTIMIZATIONS', '-DLXVST_64BIT', '-Wall', '-Wpointer-arith', '-Wcast-qual', '-Wcast-align', '-Wno-unused-parameter', '-DBOOST_SYSTEM_NO_DEPRECATED', '-D_ISOC9X_SOURCE', '-D_LARGEFILE64_SOURCE', '-D_FILE_OFFSET_BITS=64', '-DPROGRAM_NAME="Ardour"', '-DPROGRAM_VERSION="6"', '-std=c++11', '-DBOOST_NO_AUTO_PTR', '-DBOOST_BIND_GLOBAL_PLACEHOLDERS', '-Woverloaded-virtual', '-Wno-unused-local-typedefs', '-D__STDC_LIMIT_MACROS', '-D__STDC_FORMAT_MACROS', '-DCANVAS_COMPATIBILITY', '-DCANVAS_DEBUG', '-DBOOST_ERROR_CODE_HEADER_ONLY']
Linker flags: []

I also tried reinstalling it, always from repository.
Maybe I did something wrong?

Thank you,

Do you maybe mean the Editor Mixer strip? If so, check under ‘View’’ in the top menu and see if ‘Show Editor Mixer’ is selected. It can also be toggled using the key command SHIFT+E.

Yes, it works. Thank you.


1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.