Great amount of xruns and cpu load - Jack? Ardour project? kernel?

Hi all,

I have a big problem of xruns, maybe caused by a great and unusual load on the cpu by Ardour.
Here is a screenshot:

Os: Ubuntu 12.04 32 bit with Kxstudio repos: kernel, main, music, plugins.
kernel: 3.2.0-23-lowlatency
Jack: 1.9.8
Ardour: 2.8.14
processor: Intel® Core™ i7-2600K CPU @ 3.40GHz × 8, 2.9 Gib RAM
soundcards: ALESIS i/o2 usb, RME hammerfall 9652 pci

When i open the project is ok, but after a while xruns start, the audio became fragmented and the playhead goes faster. Jack constantly shows these messages:

Sun Sep 30 13:21:26 2012: e[1me[31mERROR: JackAudioDriver::ProcessGraphAsyncMaster: Process errore[0m
Sun Sep 30 13:21:26 2012: e[1me[31mERROR: JackEngine::XRun: client = ardour was not run: state = 1e[0m
Sun Sep 30 13:21:26 2012: e[1me[31mERROR: JackAudioDriver::ProcessGraphAsyncMaster: Process errore[0m
Sun Sep 30 13:21:26 2012: e[1me[31mERROR: JackEngine::XRun: client = ardour was not run: state = 1e[0m

then when i close ardour and stop jack it says:

13:21:27.312 JACK connection graph change.
13:21:27.353 ALSA connection graph change.
13:21:27.550 ALSA connection change.
13:21:27.552 XRUN callback (44 skipped).
Sun Sep 30 13:21:27 2012: Client ‘ardour’ with PID 3544 is out
13:21:31.651 Client deactivated.
13:21:31.740 D-BUS: JACK server is stopping…
13:21:31.744 D-BUS: JACK server was stopped (org.jackaudio.service aka jackdbus).
Sun Sep 30 13:21:31 2012: Client ‘qjackctl’ with PID 3439 is out
Sun Sep 30 13:21:31 2012: Stopping jack server…
Sun Sep 30 13:21:31 2012: Client ‘system’ with PID 0 is out
Sun Sep 30 13:21:31 2012: e[1me[31mERROR: Unknown error…e[0m
Sun Sep 30 13:21:31 2012: control device hw:1
Sun Sep 30 13:21:31 2012: Released audio card Audio1
Sun Sep 30 13:21:31 2012: control device hw:1
Sun Sep 30 13:21:31 2012: e[1me[31mERROR: WARNING: 53 message buffer overruns!e[0m

I’ve tried to, in order:
remove plugins, change soundcard, change jack configuration, reinstall jack, reinstall Ardour, reinstall the kernel and finally reinstall Os. Same result. …What should i try now?!
I noticed that Ardour added two more snapshots to the project, named just like two snapshot i’ve created but with the “…-2000” suffix. why? why “-2000”?

What do you think could be the problem?
Thank you in advance,

Yes, it was also my first idea, so I’ve almost immediately created another snapshot (called “no plugin”) and completely deleted (not disabled) every plugin and every volume automation, in every track or bus.
I restarted the project with that snapshot and nothing has changed, same behaviour of jack, DSP overload and noise.

Then a new snapshot has been created, called “no plugin - 2000”. …??

I also notice that the xruns started after a while, not as soon as I played the tracks.
And, most of the times, they started when the playhead went over the last region end, so with nothing playing along and none of the plugins really “busy”.

What further test should i try?
Thanks for the answer seablade!


It seems that with other projects jack and ardour behave correctly.

In the case of a matter of Ardour project , what could be the problem, if it doesn’t depends on plugins?

It almost certainly looks like the plugin load. Your CPU load on one of your cores is 100%, the DSP load has actually rotated around past 100% I suspect and is only showing 1% when it actually should be 101%, in other words it can’t process audio in the time given.

Can you go into more detail as to what you did when you say you tried ‘removing plugins’


I’ve used these plugin for that project: leet chorus (the first I removed because i thought it would be the “bad one”), invada compressor, invada meter, eq10q, multiband parametric filter, calf reverb, gverb, inverter.

Hi koivukoski, thanks for the reply.

i’ve already tried AV Linux 6.0 on this machine… the main problem was that Ardour disconnetted from Jack because wasn’t fast enough. It always happend, after a while I opened and been working on a project. I rember I solved the problem somehow, but I had also other issues with Hydrogen and other applications, so I give up quite quikly.
Do you have all the programs working well “out of the box”, without any kind of editing?

At latency values less than 11 ms i came into serious xruns’ problem. I’m wondering why my processor couldn’t enable DAZ or FTZ, just to have a try if it’s a denormal issue or not…


I`m using same processor as you do, but im not experiencing any xruns, even when jack runs on 100% loads. I used to get xruns, but I have removed all power saving properties from BIOS, and now everything works just perfect.

Here is a picture, where you can see, that im testing 1ms latency, with 10 tracks and multiband plugins & IR Reverb. DSP loads are at 100% but still not getting xruns!

Im using AV Linux 6.0 with realtime 3.4 kernel. You should try the same mayby?

  • Koivukoski1

Out of box … yes.
I make some configure, to swappiness. rtirq and elevator. This from AV-Linux manual.
I think Ubuntu is great.
Xruns are something… Kernel/Governor/Bios related.
I have termal monitoring enabled. Everything else disabled in my Bios.
Our bios c-states?

Edit: I compile Ffado 2.1.0, Fftw3, Calf-Plugins my self.


lroe@lroe-studio:~$ cat /proc/cpuinfo | egrep ‘(model name|flags)’
model name : Intel® Core™ i7-2600K CPU @ 3.40GHz
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 popcnt tsc_deadline_timer aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dts tpr_shadow vnmi flexpriority ept vpid


I read that newer processors (like mine, i suppose…) should support both DAZ and FTZ.

I also noticed that the more i reduce the latency the worst is for cpu load and xruns, even if i’m playing an empty zone of the project. is that an obvious thing or the evidence of a denormal problem?

I’m now running UbuntuStudio 12.04 64bit with 3.2.0-23-lowlatency #31-Ubuntu SMP PREEMPT kernel.

Thank you all for your help!

@lore: what type of processor do you use? if you are not sure, in a terminal window, run this command cat /proc/cpuinfo | egrep ‘(model name|flags)’, then paste the output here.

If the DSP load gradually increases when Ardour is playing silence, it’s pretty likely a problem with denormals. What are the settings in “Options | Performance | Denormal Handling”? Try switching to “Use FlushToZero & DenormalsAreZero”. If that doesn’t help, you could try enabling “Use DC Bias”.

Much more info about denormals here:

Thank you very much.
i have never heard anything about denormals before but it seems to be the point .This page analyze the problem and the possible solutions:

My setting is “No processor handling”, but i can’t change it, is not possible to enable them. is there another way to enable these options??
Enabling “Use DC Bias” doesn’t change the cpu overload and the xruns…


I wrote more than a month ago and i couldn’t find the solution…

I now reinstalled UbuntuStudio and i have the same issue, even with projects that have never given me any problem before.

Please, does anybody has an idea of that kind of problem? I can’t find so much about it in the www.

thank you,