Getting rid of the surround sound panning

I was working on a track and I noticed it had the surround sound panning and I removed alll plugins from that bus and it was still showing, I was trying to right click to see if I can reset it to i a regular panning but I don’t know what to do. I always found it annoying when it shows up but I never figured out how to get rid of it

You need to remove the output ports that “force” the choice of the VBAP panner.

You can’t use a 2in-2out or 1in-2out panner with > 2 outputs.

This can only happen if you use flexible-I/O. Create tracks & busses with strict-i/o (the default) and adding/removing plugins will never add output ports (except synths)

Assuming the track still has two inputs, and more than two outputs. Right-click on the track-header in the mixer and enable strict-i/o:

This will force the track to have the same number of outputs as it has inputs.

Alternatively manually remove them:

1 Like

And why not getting rid of the surround panner by default and give the possibility to use it only if one wants it ?
Except for rare occasions (quadraphony, octophony in circle ?), it doesn’t match the real multichannel spatial formats, even in 2D, and it has to be turned off to use a plugin or to work in ambisonics…

Right click -> Bypass. Done.

Yes, of course, but why do we need to have something that has no use and have to bypass it everytime ?
Would not it be more logical to do “Right click” -> Add Surround Panner for the few people / time where it can be used ?
I wonder how many people that use Ardour for multichannel production can use it…