Getting ardour working.... period.

Ok call me a complete newbie to this. i was using musix version of linux to run ardour 2.0 and it worked perfectly, jack made all connections, i hit play and it played :). Problem was it crashed often. not good when you almost done your masterpiece and lose everything cause the system crashes. i then discovered ubuntu media studio :slight_smile: looks awesome. problem is how do i get ardour to play something? jack seems to make the relevant connections but no matter what i do it plays back blank. Please assist me someone, or link me to a guide step by step. thanks

hi, perhaps you should go ->menu->options->monitoring->software monitoring

other ways check the option ‘autoconnect’ in the same menu.


The ‘software monitoring’ box is already ticked and the connections are on ‘autoconnect inputs to physical inputs’ and ‘autoconnect outputs to master bus’ thanks for the help but still no sound.

have you checked the alsamixer settings (mostly muted by default)?
do you get any sound out of an another appi?


The alsa mixer under soundapplications? I can get xmms working and system sounds work. Hydrogen plays. Could it have something to do with the jack settings? Does jack autoconnect on ubuntu media studio 7.04? Or do i have t connect it manually? Thanks again.

i think that jack should autoconnect, but for being sure have a look into qjackctl’s ‘connect’ window.


Are you using ardour? And if so on what linux package are you running it? :slight_smile: i been doing alot o thanking today. But here one more anyway. Thanks.

hmm, this is a ardour forum, so yes i am using ardour, the
one from the svn-ongoing branch:

svn co

on a debian-testing linux.

but did you got any sound out of yours?


Lol stupid question. Been on to many linux forums today cant remember whats what. I didnt get mine going yet but i will go on trying. I think ubuntu studio is based on debian linux maybe i should try a different one. If i cant get media studio working il change. If you can think of anything else please let me know. Cheers.

just on sunday i installed a ubuntu-feisty at my girlfriends laptop (which she just got). after the installation i opened up synaptic and installed ubuntustudio-audio package and a low-latency kernel.

after it i started a browser and went to the ardour page ‘how to compile from source…’ and than i installed some more libraries and the -dev packages of it as well as the ‘subversion’ and i was ready to go to compile ardour from sources (ongoing) which was than pretty trivial.

after it i had to change some entry in /etc/security/limits.conf and that was it, ardour was running with rt-jack and everything good.

there are a lot of good distros for pro-audio work in the moment (jacklab, 64studio, musix) but i more like my custom debian…

perhaps the reason why you don’t get any sound out of ardour is the ubuntu package, so try getting another one from 64studio (which is also debian and should be compatibel to your system). i think that musix is a debian too, but there should be packages availibel at ‘debian-multimedia’ project.

anyway, the best is if you build from sources, it is documented here on the page how you can do it and it should not be that hard…


Cant thank you enough. It seemed both debian packages had problems il try a few others and if it persists try another distro. Does the commercial release redhat support such audio apps? To be honest im new to the linux oss. A friend showed me his system and it wowed me. Between cubase and protools they havent impressed me as much as the linux apps. Cheers.

Not to discourage compiling from source or using Debian based systems, but I’m using Fedora Core 6 with Planet CCRMA and I couldn’t be happier. The setup is extremely simple, and everything worked (for me) right out of the box. Anyway, good luck in the Linux world and have a lot of fun with Ardour!

It seems there such an array of distros available im sure if i persevere il manage. Does ardour work on suse10? I think my next attempt is going t first be on ubuntu feisty fawn and install the packages from source with the media studio low-latency kernel as whiskey suggested. If that dont work i got my hands on 64 studio hopefully that will do the trick.
Thanks again.

I use ubuntu gutsy with kernel 2.6.23-rc4-rt1 (custom kernel means for me that I got 2.6.22 sources from - I mean 2.6.22, not a 2.6.22.X release, I then patched with patch-2.6.23-rc4 from, then patched it with 2.6.26-rc4-rt1 from Ingo Molnar for realtime operations). It works flawlessly with my RME HDSP Multiface II system, and it did as well with a Delta 1010 LT which I sold lately.

If you want to try Suse10, then JackLab ( might be a good option. Otherwise, you can try UbuntuStudio (, or 64Studio ( They all come with everything out of the box except for VST support which you will have to add yourself.

Thanks alot man. I downloading 64studio as we speak. If that doesnt work il try my hand at a custom kernel. I got suse10 not jacklab was just thinking o loading the packages individually but was thinking if i cant just compile the jacklab components ontop of the suse distro. Cheers n thanks again.

ok anyone got a guide on installing ardour on feisty fawn from source code?


The Building Ardour From Source document should have all the instructions you need. If you have any unmet dependencies you should be able to install them using synaptic, aptitude or apt-get or whatever, if not you may need to install them from source but the above page give links to all of the dependencies. However a recent Linux distribution should have packaged versions of everything and I don’t suspect that Ubuntu is any different.

You may find that you are better off using the 2.0-ongoing branch from SVN if you are prepared to recompile every once in a while as this is where bugs discovered in the release version are fixed.


Thanks alot. Going t try a packaged version. If it dont work il try compiling it from source. A little monthly tweaking t keep everythin working well is alright when the app is as good as ardour :). Cheers.