Getting an external mic to work in Ardour

I recently purchased a mic for recording and the YAMAHA audiogram 6 as an interface for my computer, it connects via USB. I had been running Ardour and successfully recording through the mic input built into the computer but can’t seem to get this external mic to work. The funny thing is I can record with the new mic using the default sound recorder. I was able to do this after selecting the mic in system > preferences > sound.

I have played around with the jack setup and selected the USB audio hardware as inputs but still cannot get it to work in Ardour. I may just be missing a setting in either JACK or Ardour but cannot figure out what it is. Any help would be greatly appreciated! I run Ubuntu 10.04.


show us the output of

cat /proc/asound/cards

it should look somewhat like this:

fps@mandarin:~$ cat /proc/asound/cards
0 [NVidia ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xfea7c000 irq 19
1 [Live ]: EMU10K1 - SB Live! 5.1 [SB0060]
SB Live! 5.1 [SB0060] (rev.7, serial:0x80611102) at 0xe800, irq 21
2 [M66 ]: ICE1712 - M Audio Delta 66
M Audio Delta 66 at 0xe000, irq 23

The number in front of the device you want to use wiht jack is what you put into the jackd commandline. E.g. if i want to use my delta 66, i start jack like this:

jackd -d alsa -d hw:2

this gives me the default period size (1024)…

@bholzman: your “system sound preferences” have no impact at all on JACK - it ignores them entirely. In addition, Ardour has no interest in your audio hardware - it leaves all that stuff to JACK. You should be using qjackctl to control JACK, and in the upper right area of its setup dialog you will find a selector for which audio h/w you want JACK to use. If you want to use multiple different audio hardware, that’s a bit more complicated, and you should read the JACK FAQ, specifically:

Thanks for the help! Starting jack with jackd -d alsa hw:1,0 worked perfectly! I just then had to reconnect to Jack in Ardour

Thanks again!