Genki wave ring not woking

Hello

Being on linux i converted my SWAM VSTs into LinVSTs that i can use successfully in ardour with my windcontroller (warbl).
I was able to add a midi pedal and with it i can control an arbitrary parameter of my SWAM parameter.

But this does not work correctly for my Genki wave ring.
I tried several methods in the ardour manual: after entering the surface controller in preferences as generic midi and smoothing 127,
i tried the automatic assignment of my midi messages : i move the ring after i see the automation message :“operate controller now”
but probably because the ring is sending too many midi messages at a time it does not work as it does for the pedal.

I also tried to enter my midi CCs numbers in the binding map file without more success.

I learned from a youtube tutorial that Ardour is not really the ideal software to play with wind or breath controllers…but it was in an older version of ardour.

My question is, since i’m using the 6.3 version of ardour provided by my linux distro, can i expect that it will work better with 6.9 ? or a coming soon future version?

I tried bitwig and it works well with my ring but it’s far more expansive…so before buying i want to be sure that there is no solution with ardour that i’m already familiar with.

Thanks in advance for any helpfull advice or comments.

let me add that in Ardour midi activity window i can correctly see the incoming Wave midi messages for pitchbend and for the three CCs (16, 17, 18) corresponding to the 3 directions of space spanned by the ring accelerometer and magnetometer.