General midi drum track plays back as drums, but monitors as piano

I’ve got a general midi drum track with output assigned to channel 10. When I play back the track it sounds, as expected, like drums. When I record stuff coming in from a Yamaha piaggero keyboard (with its amplifier volume turned right down) I can hear the notes being monitored by Ardour. Trouble is, ardour is playing them as piano notes. This is only a problem at record time, not at playback. Any ideas?

Perhaps the keyboard is sending MIDI notes on a different channel, and you are monitoring the raw MIDI data, but Ardour is sending the data on channel 10 only on playback. Try changing the keyboard output to channel 10 when you play.

I think it may be something like you say. Listening again, I can hear that it isn’t just coming back with piano, but an exotic mixture of drums and piano, all with a lovely delay latency.

As far as playback time goes, there is no problem in having a ‘track per instrument’ approach where the note data is all on channel 1 and the General Midi Synth associated with that track has the desired patch on channel 1. Except a drum track where you’re going to be having note info on ch10.

For a good long time I got totally the wrong end of the stick on the channel select dialog and didn’t appreciate that the channel list was all selected when in blue, rather than all unselected, which led to some bafflement when I thought I was selecting a channel when in fact it is was the only unselected channel.

In order to do the recordings, you can set channel in the channel selection dialog to ‘only Ch1’, or for drum tracks ‘only ch10’. You can set the drum track to ‘force to ch10’, but that can cause some fun later.

The problem with this setup is that although it works at playback time, at perform/record time, the monitoring doesn’t pay attention to which track is armed for recording and, if your midi keyboard is sending on ch1, it sends the events to all the instances of the General Midi Synth and blasts them out on all the instruments. In this case, the only track that doesn’t make a noise is the drum track (unless you set its input channel to ‘force all channels to 10’).

The only way I have managed to avoid ‘barnyard monitoring’ is to have each track dedicated to a different channel (rather than using just ch1), and setting the midi keyboard to send only on that channel when recording to the track. Which is obviously a monstrous pain.

I think a change request to have performance monitoring only on tracks armed for record would be a good idea. Or is there some obvious workaround I’m missing?

I thought the default was that only the selected track has the MIDI input connected. Did you change that in the preferences menu?
The option is named “MIDI input follows MIDI track selection.”
MIDI preferences page in manual

I’ve got that checked.
Since writing the above, it struck me that a more elegant workaround would be to have all tracks on ch1 but only route the midi keyboard device on the track when recording, Still a pain, but at least it doesn’t involve changing the keyboard send channel. The thing about ‘midi input follows…’ is that that is working, the input is only going into the selected track, it’s just the sound monitoring goes everywhere.

I don’t really understand what this means …

Say I have my midi keyboard (not making any noise of its own) routed as the input device on two tracks that both have a GM synth output, one track with a trumpet patch on ch1 and one with a glockenspeil patch on ch1. Both tracks are set to accepting input on, say only channel 1. I record enable the trumpet only. When I press a key on the midi keyboard, I hear the note as both a trumpet and a glockenspeil. If I actually record, it only records on the trumpet track, but while recording I hear both instruments.

that contradicts “input follows selection”. If that was being used, the device would be an input to only a single track.

I suspect that you manually reconnected at some point, at which time Ardour says “oh well, the user must know what they are doing” and stops managing the input-follows-selection logic.

Right, so you’re saying that the input routing would be done automatically when record enabling? I have 2, and sometimes 3 possible midi input devices. How would it decide which to use?

No, I’m saying that if you use input-follows-selection without ever overriding it, the input will only ever go to a single track.

You get to control which devices that applies to, in Preferences > MIDI

1 Like

OK, I removed my ‘manual’ routings from the tracks and set default values in midi preferences. When I go back to the tracks, the input device is routed on all tracks but as you say the monitoring is purely ‘per track’.

Dangerous assumption in my case

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.