frontier tranzport on ubuntu


i have the frontier tranzport, in ardour i see the option under options-control surface. i can click on tranzport, but after, it shows me this error:

[ERROR]: control protocol name “Tranzport” could not be initialized

i us ardour and ubuntustudio.

can me help somebody?



Here are steps someone else gave me to get my Tranzport working. This worked for me with Ardour 2.8.X. Please be advised this is a recompile of Ardour, and you may have to sort out your dependencies.

-------------Paste begins here--------------------

You need two particular pieces. Download this patch:

Now download this git repo :

git clone git://

Btw, I dl the git sources to my ~/src directory, you’ll see why in a
moment. When you have the Ardour 2.8.4 source tree copy the patch to its
top directory and apply it:

cd ~/src/ardour-2.8.4/
patch -p0 <Sconstruct.patch

You should see a brief report if the patch is successful.

Go to ~/src/ardour-2.8.4/libs/surfaces and move or remove the tranzport
directory. Now link your git frontier directory to the Ardour source tree:

ln -s ~/src/ardour-2.8.4/libs/surfaces/frontier ~/src/frontier

Now run scons -h and set the kerneltranzport option to 1. It seems to
make no difference if you also select the regular tranzport option.
Compile and install.

You’ll probably need to create a udev entry in
/etc/udev/rules.d/50-tranzport.rules with this content:

# Frontier Designs Tranzport
KERNEL=="tranzport[0-9]", GROUP="audio"

If that doesn’t work try adding this instead to the permissions.rules
file in /etc/udev :

# Frontier tranzport
SUBSYSTEM=="usb_device", ACTION=="add", ATTRS{idVendor}=="165b", 

ATTRS{idProduct}==“8101”,MODE=“0666”, GROUP=“audio”, MODE==“0666”

Finally make sure you read the information here:

If everything went well you can fire up Ardour and its boot messages
should report that the Tranzport is viable and the unit’s Link light
should be on. Let me know of any problems you encounter.

I’m sorry - I keep trying to paste the info in the message above, and it cuts off all of the bottom of the paste. PM me if you want, and I’ll send it to you.


Is it possible that you don’t have read/write access on /dev/tranzportX? Do have a /dev/tranzportX at all?

I’d love to know how this turned out for you. I am having the same trouble. I am a complete neophyte with this Linux thing, so I am not at all sure how to go about this. I can see the Tranzport in the Control Surfaces options, but get the same error. I don’t know how how to get or use the “git repro” shown above or how to apply the patch. I’m determined to get this thing working, but it’s baby steps all the way for me. Zendrum, is there more to the above explanation? Can I PM you too?