Frequent audio export crashes

Hello dear Ardour community!

I am new here and I wrote a little bit about me in my profile. I’ve been using Ardour for a few months now, while I’ve already learned a lot of useful things on this forum, this is my first post. I have the 4$ subscription, I am a spare time musician, however I spend a lot of time making music.

With certain sessions Ardour crashes after audio export. I’ve read about problems with audio export and was able to narrow the problem down a little bit. But at the end of the day I cannot tell what exactly causes Ardour to crash:

It happens with particular sessions only: what makes them particular is the use of certain plugins–see below.

  • Jack/Pulseaudio
    I’ve read that the audio engine can cause problems with export. But it still crashes if I don’t use Jack (only ALSA) and even after uninstalling Pulseadio.
  • Plugins
    I tried to add the plugins I’ve been working with recursively and to export both real-time and “the other export mode” hoping to understand which one causes the crash. While the results with a test session containing a very short audio region are inconsistent, the LSP Compressor is one of the main suspects.

The real sessions however, the ones with many tracks and regions and side-chaining ecc. crash consistently. Other sessions I am working on don’t crash when exporting audio – a main difference to the crashing ones is that the latter contain LSP and x42 plugins.

I will stop here, please ask if you need more information, I really hope to find a solution.

I submitted a bug report with the session file and a backtrace.

Note: The audio export works perfectly, it crashes right afterward.

Wilhelm

Start by removing the VST2 Speedrum plugin and see if that’s the cause.
If not my other suspects would be the convolvers.

It’s weird that malloc.c complains about “No such file or directory.”
Are you working in or exporting to a very long directory path or to something with weird characters?
Do the IRs exist where the convolvers are expecting to find them?

The crash seems to be caused by the x42 IR Convolver, but not by the x42 Preset Convolver.

(Also not by the Speedrum VST an the LSP Compressor, as i wrongly assumed.)

I’ve noticed the “No such file or directory.” error message:

  • the export file path is quite normal (6 subfolders from /) and doesn’t contain any weird characters.
  • The IR files are found by the convolvers, in fact the exported audio has all reverb and cabinet IRs sounding as expected.

Google suggests that the “No such file” error is simply caused by malloc crashing inside of a library. It’s supposedly irrelevant to the actual crash.

Maybe there’s something wrong with your IR or with the way the plugin handles it.
Try and use the same IR as the Preset Convolver uses.

Also, the x42-zconvolver page states that “here be dragons”, so you may have found a shiny new draconian bug :slight_smile:

I agree that the missing file error message shouldn’t be relevant since the plugins work.

Audio export doesn’t crash Ardour if I use the same IRs with the LSP Impulse Response.

Yes, I guess I caught one :dragon:

I closed the said bug report since it’s a plugin related problem.

Since Robin, aka x42, is one of the main Ardour developers I’m sure he’ll want to, time permitting, investigate why his plugin crashes Ardour with your particular IR.

You should post a report on https://github.com/x42/zconvo.lv2/issues

1 Like

Dear Peder, thank you! In fact I already went to GitHub with that intention but didn’t find where to report.

Hi,
I want to comment on 2 items:

  1. Diagnosing plugin load.
  2. Suggest a workaround to your issue.

Ardour provides a utility which details DSP plugin load. From the Ardour main menu, select “Window” and then “Plugin DSP Load”. That utility should help you isolate your plugin issue.

A workaround. To me, it sounds like you computer system is running out of resources. To test that theory, why not reconfigure your session work flow.

Instead of making your computer process everything at once, you can use Ardour’s track output settings, work for you.

If you have a bunch of tracks with high load plugins, change those tracks outputs from the master to a new mono or stereo Ardour track. Once the output is captured (recorded), deactivate and hide the original high load tracks. That way, when you go to “export”, Ardour does not have to reprocess the suspicious plugins. The overall load on your computer system will be reduced.

I do the above workaround routinely.

Finally, in another post I recommend you publish your Jack settings. It took me a while to figure out the best settings for my computer. The Jack settings can make a huge difference in either improving or reducing your computer’s performance (with Ardour).

Hope that makes sense.
Lorin

Hi Lorin,

thanks for your advice. I think that I will follow it, alternatively, maybe instead of bouncing tracks – the overall CPU load is between 40-50% for the problematic sessions – I might just continue with the LSP convolver plugin, which doesn’t crash Ardour. But then, uh, wait a sec, the only evidence I have is that Ardour does not crash after audio export if I remove the x42 convolver, but that’s all I can say from a user point of view. I closed the bug here and reported the issue to Robin Gareus at GitHub, as suggest previously, and will be more than happy to help, if I can. From a musician point of view, I learned that for now with my setup if I use the x42 convolver (note: the Preset Convolver is not involved in any crash of Ardour) after exporting audio Ardour will crash, but the exported audio will be just fine. But then, isn’t that the best time to go get some coffee and have Ardour startup again in the meanwhile. Why should software never crash anyway–I know, I’m a geek :dragon: :nerd_face: :dragon:

Edit: Oh, I think it’s relevant to point out that I am not using Jack, only ALSA, and that I also tried to uninstall Pulseaudio because I was reading on the forums that it may be a cause for the crashes.

Unless you want to compile your own Web Browsers or be limited to ones that come with direct ALSA support I would really NOT try removing PulseAudio from a contemporary Linux system that came with it by default… I say this as someone who put off using Pulse as long as I could. If you are using Ardour with the ALSA or JACK backend and not using the PulseAudio backend then exports aren’t being affected by PulseAudio anyway so removing it (or trying to) just muddies the waters further.

Many thanks for pointing that out. Reading on this forum or around the web I came across several comments concerned with Pulseaudio.

I uninstalled Pulseaudio only temporarily as an attempt to narrow down the possible causes for the crash.

Hi
I have had the same problem. Crashing after export. It wasn’t related to processor load and as far as I could tell it wasn’t a plugin issue. Sorry this was a few months ago so my memory of the details is not good. I do run all audio using Jack.
What seemed to fix it was a kernel update. I’m on Manjaro so kernel updates come along reasonably frequently. There have been several more kernel updates since then (now on 5.15) and the issue has not reappeared.
Again, I apologize for the lack of technical details here, the memory is not as young as it was… But I thought it useful for you to know you are not the only person experiencing this.

Hi,

I haven’t commented on the crashes over here any further because they
turned out not the be related to Ardour in my case. The crashes over
here were caused without any doubt by a bug in the x42 IR Convolver.
This bug has been fixed by Robin Gareus (2ba6328
https://github.com/x42/zconvo.lv2/commit/2ba6328a4b15cca07d493fa14edcf5ab367b92fc)
and Ardour doesn’t crash anymore.