Force all midi-notes in a track to same channel?

Hi

Quite new to Ardour - Impressed!

I have not yet setup my keyboard - so I have to plot in notes with the pencil.

Inserting this has a default channel for the new note one is about to create. I’ve seen it choosing channel 1 and channel 16 as the default, so obviously this depends on some setting somewhere.

  1. Is there a way to force all notes in at track to be output on a specific channel, regardless of the channel specified in the note?

  2. Is there a way to tell Ardour to use a specific channel as default, when adding notes with the pencil?

Use the midi channel selector, found in the midi track’s context menu (Right click).

I’m sorry - that doesn’t seem to work in my case.

I just tried:

The firstly created midi-track in a brandnew project:

Note-input defaults to channel 1

Setting ‘record only selected channels’ to 2:

Note-input still defaults to channel 1

Now setting ‘play only selected channels’ to 2:

Note-input defaults to channel 16

Am I experiencing a bug?

Oh … you mean I have to select the ‘use a singled fixed channel’? Oh my … :smiley:

Totally overlooked it - thnx Michael Willis!

Glad you figured it out! I’d love to hear some music from you at some point. Just curious, what kind of music are you doing?

I used to be a trumpet player - now I am going to do music for some videos I’m making at work .

My main interests are jazz and classical - but really i dig all kinds of music :slight_smile:

this is a piece i did some years ago - there’s no sequencing, it’s played on a yamaha clp-990 digital piano - it’s classical in it’s style :slight_smile:

https://app.box.com/shared/svmrp6t010

acebone, regarding our conversation on IRC, I haven’t solved this yet, but I did add the LinuxSampler config file to my project:

https://raw.githubusercontent.com/michaelwillis/virtual-playing-orchestra-ardour-template/master/virtual-playing-orchestra-template.lscp

If you’re not familiar with LinuxSampler, it’s kind of involved to import it into your project. I can help you via IRC if you need it, but generally here is what you need to do:

  • Open the project in Ardour
  • In the Mixer, on the left side, tick the "Show" column next to each of the Sampler busses:
    • Woodwinds Sampler
    • Brass/Perc Sampler
    • Strings Sampler 1
    • Strings Sampler 2
  • Add LinuxSampler plugin to each of those busses in the main mixer view (you'll have to scroll over quite a way)
  • Each sampler has 32 output channels, Ardour will assume it's some crazy surround-sound setup. Right click the surround diagram and tick "bypass".
  • Launch qsampler or jsampler, and use it to load the LSCP file that I mentioned earlier. I saved it with jsampler, but either should work.
  • Wire up LinuxSampler audio output channels to the corresponding instrument audio busses: Window, Audio Connections, Select "Ardour Busses" on both left and bottom. Refer to the table at the bottom of https://github.com/michaelwillis/virtual-playing-orchestra-ardour-template/blob/master/readme.md

At this point you should be able to expand one of the midi tracks, click the vertical piano, and hear the sound of the instrument. Once you have it working, save the project, and you shouldn’t have to launch the sampler gui again, unless you want to change around the instruments.

Track Midi Channel Assigment is a little inconsistent. I am not sure if I am hitting a bug. I have controller keyboard assigned to a midi track that I have assigned to channel 10 - and that outputs midi to a external module (roland sc-88).
I hit the virtual keyboard inline in the track and it works, but I lay down my drum track real-time with the keyboard.
So, when I wire/assign my keyboard to the drum track (midi track ch.10) via. Catia/jack, the midi track is sending signals to midi channel 1.
I play the virtual keyboard and I see and hear the ch.10 of the module, but the controller keyboard mapped to it is sending ch.1.
Is this a bug? or is this a special undocumented feature :slight_smile:
Anyways I would love to know if someone knows how to fix this, I am itching to lay my drum tracks.

There’s really no such thing as “Assigning a MIDI track to channel 10” (or any other channel). Anything connected to a given MIDI port will see/receive all data that arrives on that port - the question is whether and what it does with the incoming data. A given MIDI-handling device or program might ignore data marked for certain channels, or map it to another channel, or totally ignore channel number entirely, etc. etc.

One problem here is that there is some significant confusion in ardour regarding the function of the MIDI channel controls for a MIDI track. In current versions of Ardour, this ONLY affects inbound MIDI data, and never affects data already stored in the track (i.e. recorded, or entered using the GUI in various ways, or imported from an existing MIDI file). We plan to change this in a future version so that it can be used to alter incoming and outgoing data.

However, having said that, it isn’t clear from your description whether the problem is in your controller keyboard or not. If you assigned it to channel 10, then it should be sending events marked for channel 10, and ardour should record them that way. Can you describe the problem again, with even more detail, and then we should be able to help.

Thanks Paul (nice name by the way!),
Let me state my goal I guess, and perhaps you can help guide in how achieve it.

  1. I want to play the drum kit in my Roland SC-88 on MIDI channel 10 in Ardour via a MIDI track, call it DrumKit (not succesfully yet),
  2. I am routing that audio back into Ardour and recording it on an audio track in Ardour from the sc-88 (works great so far for channel 1 & 2, for other instruments)
  3. I want to use my keyboard to play the drum patch in Ardour for DrumKit Midi track, So I route my Keyboard to the DrumKit Midi Track (via Catia/Jack).
  4. I assign DrumKit midi track to channel 10 (and set Inbound/Playback to “Play only selected channels” and assign channel 10), I play the virtual keyboard on that track and wahlah! I see the channel 10 signal and hear the kit coming from the sc88 on the midi monitor.
  5. I play the keyboard, that is only routed to DrumKit midi track and it is playing only channel 1 of the sc88, even though all other tracks have the Midi Input disabled, I see in the Midi Monitor channel being sent out of DrumKit midi track. So it seems to me, that I should be seeing only channel 10 signals routed through DrumKit midi channel, but the keyboard routed to DrumKit is sending signals to midi channel 1 via midi out for the same track.

I want the physical keyboard connected to DrumKit to send signals like the virtual keyboard to channel 10, so that it can be played realtime, but this is not happening, DrumKit midi track is sending via midi out to channel 1 for the keyboard and channel for the virtual keyboard, this seems like a bug to an end user like me.

How do I get this to work as desired?
Thanks for all your help, in advance!

Forcing MIDI Channel for Midi IN/OUT

Well, I solved my problem in a round about way. I used QMidiRoute to route my keyboard midi out to send out only on midi channel 10. Then routed (using Catia) the out of QMidiRoute to the Midi In of the DrumTrack assigned to channel 10 going to the in of the SC-88 and wahlah! It all works like it was meant to be. Hallelujah! I can now play my keyboard routing it indirectly to Ardour (via QMidiRoute) and recording the input into an audio track. I am at least now functional and happy, but it would be really sweet, if I could dump QMidiRoute (nice tool don't get me wrong, thank you whoever authored it!), and directly route my keyboard into the DrumTrack and change any midi channels within Ardour if they are goofy like this situation. It just seems really strange that if the track in Ardour has the channel selected for Playback to be "Play Only Selected channel" assigned to 10 or "Use a single fixed channel for all playback" set to 10, that it would do just that! Not send to channel 1 for a midi keyboard and channel 10 for the virtual keyboard. Anyways, Ardour is an fantastic product!!!!!!!! and you folks out there CONTRIBUTE TO THEM!!! to keep them doing what they do~!! I have and I will continue!