Foldback OSC control - /cue/bus index does not work

Hi, I’m configuring Ardour to use personal monitoring and control with OSC, I managed to use the other commands, except the /cue/bus index command, maybe I’m using it wrong.

For example, I added two foldback tracks, when I send /cue/connect, I can control the monitoring well with /cue/send/fader/*, and when I send /cue/next_bus, it moves to the next foldback track, but I couldn’t specify foldback guide I want to use sending /cue/bus index.

I tried /cue/bus 2 or /cue/bus 1, or even /cue/bus Foldback 1, and I didn’t get the expected response, could anyone tweak me?

Thank you very much in advance!!

/cue/bus i 1 or /cue/bus f 1 should both work (that is the parameter can be either float or int). They call the same code as /cue/next_bus… so let me try that here. It does work… but perhaps not as expected.
using oscsend and oscdump in two terminals:
oscdump is setup like:
oscdump 8000
then oscsend localhost 3819 /cue/bus i 2
gives this output in the oscdump screen:

e513068f.8adf1e07 /cue/name/1 s “Foldback 1”
e513068f.8ae31d70 /cue/name/2 s “Foldback 2”
e513068f.8aea52ef /cue/name s “Foldback 2”
e513068f.8aee84ac /cue/mute f 0.000000
e513068f.8af30a4d /cue/name s “0.00”
e513068f.8af62f9c /cue/fader f 0.781787
e513068f.8afae791 /cue/send/name/1 s “Audio 2”
e513068f.8aff4ba4 /cue/send/name/1 s “-inf”
e513068f.8b034b0d /cue/send/fader/1 f 0.000000
e513068f.8b076c04 /cue/send/enable/1 f 1.000000
e513068f.8b0b6b6d /cue/name/3 s “Foldback 3”
e5130690.391cf355 /cue/name s “Foldback 2”
e5130690.3921144c /cue/send/name/1 s “Audio 2”

There is no /cue/bus returned but in general the name should be of more interest because it is human readable. In your case, because /cue/next_bus works, and the output is the same, I would guess there is something about how you send the message. Is the parameter either an int or a float? It will not work if it is a string ( “1” ) for example. It must be sent as a number.

If you do not know what your control surface sends, under preferences->Control Surfaces click on OSC and then Show Protocol Settings. This will open the OSC dialog and in the OSC set tab there is a drop down for: Debug. Set this to Log all messages. Then select Window->Log from the top menu bar and you will see what messages Ardour is receiving from your control surface. It will look something like:
2021-10-14T12:42:07 [INFO]: OSC: /cue/bus i:2
Where the 2 is an integer and:
2021-10-14T13:03:06 [INFO]: OSC: /cue/bus s:2
where the 2 has been sent as a string (which will not work and should really show:
2021-10-14T12:47:38 [INFO]: Unhandled OSC message: /cue/bus s:2 )

2 Likes

This helped me a lot, thanks! problem solved.

How Float worked well, sending a signal to the ardor /cue/bus f:2 (and so on according to the sequence that adds new foldbacks, 1, 2, 3, 4… and so on)

In the open stage control (https://openstagecontrol.ammd.net), I put /cue/bus under address and the foldback identifier number I put in “button on: 2”, so that indexes to the second foldback added.

And another app I use is OSC Controller (https://play.google.com/store/apps/details?id=com.ffsmultimedia.osccontroller&hl=pt_BR&gl=US) for android, where I use a gridbutton with address /cue/bus and in value the foldback number specified, getting:

Thank you very much @lenovens !

Your welcome. I hadn’t seen that android app, it looks nice. I have used touchosc before because it can be used on either android or iphone but it costs money. I will have to play with that.