Focusrite Scarlett 18i20

Okay I got myself in quite the pickle…
First, I apologize if this isn’t specifically Ardour but the Linux Musicians forum is dead.
I have been using a first generation Scarlett 18i20 for around 5 years now. Been working great. 3 years ago, I incorporated an Octopre Mk II via the ADAT input of the Scarlett to give myself 8 more input channels. Also, was working great.
It was brought to my attention a 2nd Scarlett can be used in place of the Octopre which would also give me 8 more analog outputs via the first Scarlett’s (the one acting as soundcard) ADAT output. So I went to get a second Scarlett but the only first gen ones for sale costed more than a new 2nd gen. I’ve been hearing for years that the 2nd Gen is working with ALSA, so I went for it.
ALSA shows a single parameter for the 2nd gen, which is the clock source. I installed kernel 5.11, same thing. So I hooked it up to a Windows box, and set the routing so it would send its inputs out the ADAT and send the ADAT input channels to its line outputs. Now when I hook it up the original Scarlett (the one that is acting as the soundcard) it doesn’t send audio to the DAW or take signals.
Anyone using a second generation Scarlett and have any tricks for getting ALSA to configure it? I found this page:

But I don’t know what to do with it. Do I find those files on my system and make exactly those edits? Do I even need to do that at this point? I thought those changes were already incorporated in the 5.x kernel.
Sorry for all this. Just if anyone with a second gen can think of something obvious I am missing.

Hi I have a second gen 18i20 but, I do not fully get what your trying to ask?

Hi, I appreciate the reply. I guess my most immediate question is does ALSA show you all the routing options and whatnot for the 2nd gen 18i20? Because mine literally only shows the clock source option and nothing else. This is both with alsamixer in the terminal as well as the Qasmixer UI.

Hi Saam, Scarlett 2gen should work since kernel 5.4. But, you need to activate the 2 gen scarlett internal driver.

  1. make a file in /etc/modprobe.d/scarlett.conf with this content :
    options snd_usb_audio vid=0x1235 pid=0x8201 device_setup=1,1,1,1

  2. turn off scarlett 2 gen. and reboot

  3. in a terminal do : journalctl -f

  4. turn on your scarlett 2gen.

you will now see in terminal if scarlett 2 gen works.

you can use alsamixer and quasmixer for routing and adjust levels.

3 Likes

thank you so so so much. that did the trick.

Unfortunately this did not work for me. I see something happening in journalctl -f though, but alsamixer still only shows clock source.

did you verify that the .conf file was saved? did you copy the syntax exactly? did you restart the computer and the scarlett? finally, what version of the kernel are you on?

Sorry for the lack of details :slight_smile:

I am sure the conf file is saved.

I did copy the syntax exactly but the product id differs, 8215 in stead of 8201:

$ lsusb
...
Bus 003 Device 005: ID 1235:8215 Focusrite-Novation Scarlett 18i20 3rd Gen
...

So I ended up with this line in /etc/modprobe.d/scarlett.conf:

options snd_usb_audio vid=0x1235 pid=0x8215 device_setup=1,1,1,1

No that I read a little more careful I see I own a 3rd gen btw.

I did restart both the card and the computer.

Kernen version:

$ uname -r
5.10.26-1-lts

Thanks for your reply,
Erik

If you are familiar with compiling kernels you can check out this backport driver from sadko. There are more resent work on the driver here. backport 18i20 from geoffrey
Hope it will work out for you.

Linux Musicians forum seems pretty lively. Particularly hardware:
Linux Musicians Hardware

Yeah I posted on a thread regarding this exact problem, and tried to ask for some specifics/clarifications and got not replies lol. but i’m glad there are plenty of others appreciating the forums. i think i like it better here :slight_smile:

i would look into whatever cjoke posted. the original instructions are for 2nd gen. i didn’t even realize there was any effort in getting the 3rd gen working on linux.