Focusrite 18i20 and Octopre ADAT connection

Hello.

I’ll use Ardour next week to record a band.

I have a Focusrite 18i20 and a Scarlett OctoPre Dynamic, i linked them together as explained in the manual taking care that the 18i20 is the World Clock master.

I can record in Ardour from the 18i20 but in don’t manage to do it from the Octopre. I tried to figure out how to make ADAT routing in QasMixer, but i guess i don’t understand how it works exactly.

I put the Clock Source on Internal.
“ADAT 1 : PCM 09”, “ADAT 2 : PCM 10”, etc. in the capture window.

But after that, what am i supposed to do ?
To route PCM 09 to ADAT Output 1 ?
Or to route ADAT 1 to ADAT Output 1 ?

I didn’t understand what are the “Mixer Input 01 to 18” also, how am i supposed to use them ?
Same for Mix A,B,C,D etc. Inputs, i don’t understand their routing and if i need them.

So if you can help, thanks a lot !

I use an 18i20 + Octopre with ardour.

I set it up with the 18i20 as the master clock I use BNC wordclock to link them.

This setup has worked really well for me, but I’ve just used ardour without any other mixer applications so I can’t help with what Mix A,B,C,D inputs are. ardour just uses numbers.

When you go to Ardour’s Audio connections patchbay window (Alt-P) do you see all of your inputs in hardware sources tab on the left hand side and the outputs on the hardware destinations tab on the bottom?

In ardour
The analogue inputs to the 18i20 show up as 01->08
The S/PDIF inputs are 09 and 10 (I don’t use these)
The inputs to the octopre show up as 11->18

I can’t remember the outputs of the top of my head, I think the headphone outputs can be routed in the windows setup application (which runs in wine without issues) However, the setup application is not needed, Ardour is flexible enough to route monitoring, sends etc as you need and you can set up a template to remember it all for a new session.

The only issues I’ve ever had were I used to get a problem where some (or all?) of the inputs were muted by alsa when I started up, I just went to alsamixer an unmuted all the inputs. (It was very embarrassing trying to figure this out in front of a band the first time though!)

Just a thought, you haven’t mixed up inputs and outputs have you?

I’ve a feeling that focusrite may use Mix, A, B, C, D to name it’s outputs.

i.e. Mix would be labelled outputs 1,2 in ardour,
A => 3,4
B => 4,6
C => 7,8
D => 9,10

Thanks for your very quick answer and help ! Really ! :slight_smile:

[quote] I use an 18i20 + Octopre with ardour.

I set it up with the 18i20 as the master clock I use BNC wordclock to link them.[/quote]

Ok, it’s what i tried to do.
Here are two pictures showing how i connected the 18i20and the Octopre :


[quote]This setup has worked really well for me, but I’ve just used ardour without any other mixer applications so I can’t help with what Mix A,B,C,D inputs are. ardour just uses numbers.

When you go to Ardour’s Audio connections patchbay window (Alt-P) do you see all of your inputs in hardware sources tab on the left hand side and the outputs on the hardware destinations tab on the bottom?[/quote]

Yes i see them, there two screenshots here :

[quote]In ardour
The analogue inputs to the 18i20 show up as 01->08
The S/PDIF inputs are 09 and 10 (I don’t use these)
The inputs to the octopre show up as 11->18[/quote]

I have the feeling i messed up the routing using QasMixer, right now it’s like this :



I tried to install Focusrite Control through Wine (Focusrite Control - 3.6.0.1822.exe), but when i try to launch it it asks to install an update of the system (Windows6.1-KB3033929-x64.msu).
I tried through VirtualBox, it didn’t recognize the 18i20.

Anyway if i understand well it should be possible to route it correctly through QasMixer and Ardour.

How did you unmute it exactly ?

Ok, sorry for the disturbance, it now works.

Obviously one of my two optical outputs doesn’t work properly. I remade the cabling and trieed plugging the Toslink cable in the other one. And it worked.

There are still some mysteries for me about the routing, but well i can use the 16 inputs and it’s what i needed so i won’t complain. Thanks again ! :slight_smile:

1 Like

Glad it’s working! Have a good session :slight_smile:

may I ask : what Focusrite 18i20 are you using exactly, 3rd generation or before? I am looking into getting a similar setup and check options new and second hand… thanks!

Sorry for the late answer, i was busy recording by the way. I used the 18i20 2nd generation. Everything worked very well :slight_smile:

1 Like