fn (second function key) on macbook pro doesn't work in ardour?


sorry if this has been posted, I did search the forums first with no info.

Ardour doesn’t seem to recognise the second function key?

i.e. pressing fn makes the return key become the enter key

Am I doing something wrong or is it just something that has not been implemented with Ardour? (using 3 beta osx)


  • Luke

Going off memory, I believe the default keybinding is actually Keypad-Enter to insert the marker, which I think is actually slightly different than Fn+Return, but don’t quote me on that. There are several idiosyncracies with Apple that they do different from everyone else, but it has been a bit since I tried to do what you are doing on a Macbook Pro or Powerbook.


One of the main things I’m struggling with at the moment is this issue in terms of markers.
I had to reset the key bindings to just be the return key for when I’m adding a marker from play point. I tried to hold down the fn key at the same time but it would still just come up with return.

I might need to set it up with cmd return or something similar, but to me fn seems more intuitive in this instance.