FluidSynth loses right channel

Hi folks,

I’m currently experiencing something odd in an Ardour session.
Got a variety of MIDI tracks, some of them using sfizz as intrument, some of them using ACE FluidSynth. Everyting OK.

Here’s the deal with one of the tracks:

  1. Track produces sound (stereo)
  2. Quit and restart Ardour
  3. ACE FluidSynth outputs sound only on left channel … (visible in the meter bars)

Track Panning is OK
MIDI Panning CC is OK (changing it, I end up with sound on left channel only or no sound at all)
Pin connection of ACE FluidSynth is OK
Using MIDI Monitor, there’s no particular MIDI CC being output to the track …

Even weirder, if I replace ACE FluidSynth by CALF FluidSynth and do the same (quit / restart) I get the same result !
Changing the SF2 for another one doesn’t make a difference …
If I use ACE ReasonableSynth, then there’s no issue …

Behavior is the same if after restart I just play notes with MIDI keybaord instead of actually playing the track so it doesn’t seem tied to the content of the track itself.

Only solution at the moment is to remove the plugin, re-insert the plugin; only then are we back to normal …

Any thoughts ?

Investigating further, I created another track with the exact same config (sames soundfont, etc) and this one is unnafected.

What’s odd is that in fact, with the MIDI monitor on the track, I see some strange messages that I didn’t create !
Screenshot_20220416_085120

MIDI monitor on the left is the bogus track - the one on the right is the new one I created. The CC 10, 11 and PBend are mine.
But no clue where all the Program changes come from and I don’t even have a clue what KP is !?!

Even weirder, I tried to change the playlist of the track for a new empty one and these messages still appear !

I made sure the MIDI input is disconnected, so it’s not coming from somewhere else …

I guess I’ll just copy my plylist to the new track and move along but I’m still curious what could be the cause of this mess.