first stumbling steps

Dear Forum,

Forgive me my probably silly question, but I have just started to enter the Ardour/Linux-World and could not find help elswhere. I use Ubuntu-Studio and a Tascam US-122. The latter is correctly installed because in Audacity I can record properly. But as far I can see Audacity is not using JACK, but refers to ALSA directly.

When I try JACK+Ardour there is no input. JACK is running and Transport activated. The Input-source of my tracks is set to Capture_1 and Capture_2. Does that sound correct? And what are the most obvious things I could have missed?

I’d be thankful for any hint,


The most obvious thing I can think of is this: Have you activated the red button of the track you want to record to, in addition to the big red button in the transport?
In addition, you can check that you really have the “captures” connected to the track or tracks you want to record to by means of the connect button in qjackctl.
By the way, this one can be useful:
I hope it helps

Edit: Oh yes, check this one too:

Thanks for your answer and sorry, I had been offline for a while.
Of course I used the recording-button correctly. When I try recording, a wave-graph is created but with no signal on it. The Captures seem to be connected properly to the ardour-tracks in JACK. In your two links I did not (yet) find anything that solved my problem.

Here is the messages I get from Jack, while I fumbled a little with the settings.

13:21:23.520 Patchbay deactivated.
13:21:23.689 Statistics reset.
13:21:23.701 Client activated.
13:21:23.914 JACK connection change.
13:21:23.919 ALSA connection change.
13:21:23.955 XRUN callback (1).
13:21:26.389 XRUN callback (2).
13:21:27.415 XRUN callback (3).
13:21:27.727 XRUN callback (1 skipped).
13:21:30.872 XRUN callback (4).
13:21:36.249 XRUN callback (5).
13:21:37.997 Transport start.
13:21:38.140 Transport stop.
13:21:38.811 XRUN callback (6).
13:21:39.495 Transport start.
13:21:39.543 Transport stop.
13:21:40.780 Transport start.
13:21:40.946 Transport stop.
13:21:43.479 XRUN callback (7).
13:21:45.286 XRUN callback (2 skipped).
13:21:47.289 XRUN callback (1 skipped).
13:21:48.166 XRUN callback (12).
13:21:52.391 XRUN callback (13).
13:21:59.944 XRUN callback (14).
13:22:03.529 XRUN callback (15).
13:22:05.313 XRUN callback (1 skipped).
13:22:05.965 XRUN callback (17).
13:25:30.746 XRUN callback (132).
13:25:34.715 XRUN callback (133).
13:25:35.609 XRUN callback (1 skipped).
13:25:41.248 XRUN callback (136).
13:25:43.810 XRUN callback (137).
13:25:50.595 XRUN callback (138).
13:25:53.222 JACK connection graph change.
13:25:53.234 JACK connection change.
13:25:53.255 JACK connection graph change.
13:25:53.412 XRUN callback (139).
13:25:53.436 JACK connection change.
13:25:55.717 XRUN callback (140).
13:25:57.767 XRUN callback (141).
13:25:59.647 XRUN callback (1 skipped).
13:26:04.170 XRUN callback (143).
13:26:09.163 XRUN callback (144).
13:26:11.164 JACK connection graph change.
13:26:11.264 JACK connection change.
13:26:11.667 XRUN callback (3 skipped).
13:26:12.501 XRUN callback (149).
13:26:13.671 XRUN callback (1 skipped).
13:26:14.553 XRUN callback (151).
13:26:15.675 XRUN callback (1 skipped).
13:26:19.551 XRUN callback (154).
13:26:21.684 XRUN callback (1 skipped).
13:26:22.885 XRUN callback (157).
13:26:23.911 XRUN callback (158).
13:26:25.577 XRUN callback (159).
13:26:25.689 XRUN callback (1 skipped).
13:26:30.570 XRUN callback (160).
13:26:31.724 XRUN callback (161).
13:26:33.008 XRUN callback (163).
13:26:33.699 XRUN callback (2 skipped).
13:26:36.093 JACK connection graph change.
13:26:38.257 XRUN callback (164).
13:26:39.283 XRUN callback (165).
13:26:39.709 XRUN callback (2 skipped).
13:26:41.207 XRUN callback (167).
13:26:43.257 XRUN callback (168).
13:26:43.557 JACK connection graph change.
13:26:43.717 JACK connection change.
13:26:47.482 XRUN callback (169).
13:26:48.735 JACK connection graph change.
13:26:49.659 XRUN callback (170).
13:26:50.362 JACK connection graph change.
13:26:52.223 XRUN callback (172).
13:26:53.505 XRUN callback (173).
13:26:53.737 XRUN callback (1 skipped).
13:26:54.787 XRUN callback (174).
13:26:58.500 XRUN callback (175).
13:26:59.782 XRUN callback (176).
13:27:01.748 XRUN callback (2 skipped).
13:27:03.627 XRUN callback (179).
13:29:07.905 XRUN callback (1 skipped).
13:29:08.291 Transport start.
13:29:08.307 Transport stop.
13:29:10.095 Transport start.
13:29:10.110 Transport stop.
13:29:11.121 Transport start.
13:29:12.575 XRUN callback (213).
13:29:14.499 XRUN callback (215).
13:29:15.318 XRUN callback (1 skipped).
13:29:17.322 XRUN callback (1 skipped).
13:29:17.961 XRUN callback (218).
13:29:20.523 XRUN callback (219).
13:29:22.959 XRUN callback (221).
13:29:23.341 XRUN callback (1 skipped).
13:29:25.345 XRUN callback (4 skipped).
13:29:26.557 XRUN callback (228).
13:29:27.350 XRUN callback (1 skipped).
13:29:28.479 XRUN callback (229).
13:29:29.355 XRUN callback (1 skipped).

I have also considered connecting to the IRC-channel for support, but did not find a way how to register with I have an irc-client (pidgin) installed but it asks for an existing account. How could I create one?


Have you set up JACK as described in these instructions? First, you should check to make sure your US-122 is connecting to JACK correctly. With a microphone connected to your US-122, start JACK and open the Connections window, then connect capture_1 to playback_1. Can you hear the microphone?

Just enter from the link provided in the Support tab and change the nickname. I think you don’t need anymore.
You have lots of xruns! yes, check JACK instructions.

Ah! Thanks - this was the link I had long searched for. After I selected the right hardware-device and adjusted the frames-rate I dont get xruns anymore.
Yet I have swapped one problem for three more:

  1. In the JACK-settings I can only select the “US-x2y” (hw:1) and one of its two inputs (hw:1,0). If I select the former I dont get anything to connect in the JACK-connections window (no “system”, no “ardour”). So I have to choose the first channel only. But this might be a driver-problem I have to solve separately.

  2. If I connect capture_1 to playback_1 I hear nothing. I tried to check the alsa-mixer but “alsamixer -c 1” gives me “no mixer elems found”.

  3. When I try recording in Ardour, it always stops after 5 seconds and tells me my harddisk was too slow. I use a recently bought Thinkpad R61 so I dont think this is the case. I also think it did not do this last time I tried it.

edit: It also tried H/W-Monitoring, as someone on the linked page suggests, and connected
also_pcm-Monitor_1 to playback_1. If I do this in addition to connecting to capture_1 then i get a humming noise, that increases with every time I speak into the microphone. This was the closest to recording I have got yet. Any ideas?

Hi Artur!
If you use the Search function on top of the page and enter US-122 you will see several posts on how to get it working with alsa and jack. Then you may post in one of these threads if you have more specific questions.
I really cannot help you as I use a PCI card and don’t know about USB devices.
The “hard disk too slow” issue has also been discussed here.
I’m sure you’ll see things clearly and have your system up and running soon.

Thank you very much, Pablo! I have rarely been pointed to the search function as polite.

Yet it seems I am not even smart enough to get this one running. For “us-122” I get only 15 hits, most of which are hardware recommendations. None seems to get me much further - especially since my driver already works (even though one input only), since recording and playback works fine with Audacity. My main aim is to get running Ardour. The second input can wait.

For “hard disk too slow” I get exactly one hit - this thread. And a wider search did not help either.

Anyway. I will search on and keep my eyes open for any information.

Hi Artur,

I am using my US-122 with ArdourVST 2.5 in Gutsy. It works fabulously so you should be able to get your’s running too…

Do you have all of these packages installed?
alsa-firmware, alsa-firmware-loaders, alsa-tools, fxload. Also are you using the Ubuntu -rt kernel?

It seems to me that there is something not quite 100% working with your firmware,

My Us-122 appears as “TASCAM US-X2Y…”
in Qjackctl. You’ve indicated yours doesn’t.

I would suggest using the alsa-firmware package at:

In fact I would add this repo and it will provide you with all the latest packages for alsa, JACK, Qjackctl etc.

These are my settings with my US-122:
Realtime checked, Frames per period 512, Buffers 3, Sample rate 44100.

Note there is no Alsa Mixer application for the US-122, You monitor your input using Ardour’s VU metering when you arm your track to record.

Hope this get’s you on the right track.

Hi GMaq,

As far as I can see everything you name is in place. Alsa-firmware is not a package, right? because it does not show up in Synaptic. But I have copied the extra firmware-files into the right place, when I set up my installation, if this is what it means. And as I say: it works with Audacity (without Jack).

I may have put it misleadingly above: The full entry in qjackctl is indeed “hw:1 TASCAM US-X2Y”. But when I select it, I do not get a single input to connect in Jack. I only get some when I pick “hw:1,0 US-X2Y Audio #0”.

Anyway, the most reasonable thing indeed seems to be to update my system against these new repositories first. I just have to wait until I have enough bandwith for that.

thank you,



That may be your problem…

The former way of installing the US-122 firmware was to download the ALSA firmware, Unzip it and as root create a “firmware” folder in /usr/share/alsa/ and create a udev rule in /etc/udev/rules.d/ The udev rule came from an ALSA Wiki page about the US-122. Is this how you installed your US-122?

I had some difficulties with my US-122 killing JACK after 120mins using that setup, however not the same ones that you are experiencing.

I installed the Alsa-firmware (It is a package) from ematech, it creates a different udev rule for the US-122, and voila it works great.

The only caveat is that you will need to delete or comment out the original tascam-55 rules in the /etc/udev/rules.d/ folder after you install the ematech Alsa-firmware package.