first midi note at the beginning does not play

Hi all, Ardour 6.9 in linux Debian unstable. If I use jack transport, the very first midi note at the beginning does not play. If I use internal, it does. Could you please help me to solve this? With Ardour 5 from kxstudio that was not happening.
But after upgrading to the newest version, it happens.

The surprising bit is that this didn’t happen in Ardour5. It is a math rounding problem, depend on sample-rate, BPM and region-postion, it may well be that you were lucky so far.

Yes, I think those are similar.
I hope the issue is still the same so it will be hopefully solved in Ardour 7, but it occurs to me just at the very beginning of the time line, so at 00:00, anche just when in source (JACK) transport.

Being like that, I cannot move on the left the region.
So as workaround, I can move on the right by a measure and maybe everything go fine.

Is there anything in JACK settings that can be done?

I wait for 7.
many thanks!!!

Update:
I’ve downloaded Ardour 7 nightly build.
The issue still remain, it is not solved yet.

Just to let know that maybe what is happening to me is something that has to do with jack configuration.

I wish to remark that the issue happen to me just when I use SOURCE transport, i.e. sync with Jack Transport.

If I use INTERNAL, everything is good.

Luciano

Please provide substantially more detail, preferably via a bug report at tracker.ardour.org, with the session where this happens attached, and details on the sample rate and buffer size that you are using.