"Find a trout" error after upgrade from Debian 11 to Debian 12

I love that error message. Just saying… :slight_smile:

I’ve upgraded a system from Debian 11 to Debian 12 and all is fine, except Ardour fails on launch unless Jack is already running. Here are the last few lines of the terminal session, including Best Error Message Ever.

UPDATE: I launched a Debian 11 instance, hoping to find a clue, and realized that all this term-session stuff is the same back in Deb11 land as well. So… no clue there, but I’ll leave the transcript in this post anyway because… the error message.

Ardour: [INFO]: Loading ui configuration file /etc/ardour7/clearlooks.rc
Ardour: [INFO]: Loading bindings from /etc/ardour7/ardour.keys
Loading ui configuration file /etc/ardour7/clearlooks.rc
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock

repeated a few times…

Find a trout and repeatedly slap the nearest C++ who throws exceptions without catching them.
Ardour will likely crash now, giving you time to get the trout.
audio-midi engine setup failed.

Could it be that you have replaced jack with PipeWire during the update?

Does it also happen if you use Audio System: ALSA instead of JACK?

1 Like

Hi Robin, thanks for dropping in.

I don’t think the upgrade added Pipewire. I’m using the Xfcd desktop and, after some rummaging, haven’t found any references to Pipewire in the desktop UI. Task manager doesn’t find any Pipewire processes.

ALSA is hard to configure in Ardour’s Audio/MIDI setup window because this is a headless cloud server taking advantage of Jack’s DUMMY option.

I just stood up a from-scratch version of the server with Deb12 and Ardour launches fine. So it may be a configuration setting that carried over from Deb11.

UPDATE: this happens across three servers that I’ve updated from Deb11 to Deb12. I’m standing up a fresh Deb12 and will take a look at the config file in that system. any places I should look besides ~/.config/ardour7/config ?

Hmm… what do you think of deleting the old .config file and letting Ardour recreate it?

I doubt it makes a difference, but you can try. I suggest to just

mv ~/.config/ardour7 ~/.config/ardour7.bak

So you can later restore or diff it.

Another thing to try, after starting jackd, run jack_lsp in the same context that Ardour would run and check if that can connect to JACK. perhaps it’s some cgroup issue.

Curiouser and curiouser.

First try – edit out some some funky section entries in the config file. It worked. Once. Ardour started normally and at the end it wrote a new entry into the XML. But the second time I started it, it returned to that fabulous error message.

Second try – delete the config file and let Ardour rebuild the whole thing. Same result. Ran once, but failed on the second run.

Everything’s fine if I start Jack first.

I’m signing off for tonight, and I’m OK with the “start Jack first” workaround.

UPDATE – forgot to try your jack_lsp suggestion. I ran it with Jack and Ardour already running. It worked. Also worked with just Jack running. Didn’t work when Jack wasn’t running.

UPDATE2 – I noticed this error message in the Ardour log. I don’t think it’s relevant, but installing the package cleared the error. It’s funny that it didn’t get updated during the upgrade.

2023-06-15T22:45:29 [WARNING]: Video-monitor 'xjadeo' was not found. Please install http://xjadeo.sf.net/ (a custom path to xjadeo can be specified by setting the XJREMOTE environment variable. It should point to an application compatible with xjadeo's remote-control interface 'xjremote').

see also http://manual.ardour.org/video-timeline/setup/

Install the 'ardour-video-timeline' Debian package!

Methinks there is a typo in the error message. It should read: “Ardour will likely crash now, giving you time to gut the trout.”

1 Like


and it should also read “…slap the nearest C++ developer…”

1 Like

Sure it does… AFAIK on Debian 12 it has become the default, replacing pulseaudio.

Hi, a Fedora user here, so maybe I’m making things more difficult for you than needed: as I really like to see what’s happening with the audio-engine I make sure Ardour starts without autostarting the audio-system.
In the menu “Windows” the top option is “Audio/Midi setup”. This gives a window where you can select your audio-system and a button “Autostart”. Set this to “off”.
The next time you start Ardour and select a project (or create a new) you get this window and the opportunity to check your devices (Alsa/Jack/Pulse/… sample frequency) and on the right side bottom a [start] button. This could help to find where Ardour or your settings clash.
And my personal preference: use Alsa

Sorry, I don’t know a lot about Pipewire. But I think it may vary by desktop. I read in various places that it’s the standard in the Gnome desktop. Pulse Audio is what my desktop (Xkcd) loaded however. Not a big deal – I need to use Jack for other reasons.

Well, pipewire is a general purpose multimedia subsystem, designed to fulfill both common desktop and “pro” audio (and video) requirements. It is meant to eventually replace both pulseaudio and Jack.

It includes compatibility layers to support legacy applications designed to work with both pulse and Jack (as well as ALSA).

That’s why it may likely clash with “true” Jack.

Although it’s still a young and unfinished project, pipewire has been already adopted by default by several distributions. Debian did so since version 12 “bookworm”. Though it looks like for the current release that’s true only if the Gnome desktop is installed (you’re probably right about that):


Xkcd? Perhaps you meant XFCE? :thinking:

Anyway, the fact that “you think you’re using pulse” (I mean, that your DE “believes” so) does not necessarily imply that you’re actually using pulse. :crazy_face: It could be as well that it’s using the pipewire-pulse compatibility server instead. You should run “pactl info” to be sure.

Here what comes out of that command if you are actually using pipeware-pulse instead of “real” pulse:

Look, this thread isn’t about Pulse Audio or Pipewire. Robin contributed a couple excellent suggestions at the top. One of his questions was whether Pipewire might be contributing to the puzzler. It’s not. Forget all the rest of this froth.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.