film and soundtracks

Hello everyone,
I’m pretty interested in using Ardour but what I usually do is film stuff.
I installed xjadeo and it seems work out of the box with Ardour.
There’s some “standard tech” issue to sort out though.
Usually the first frame of a video start at 01:00:00:00 or hours different from 00:00:00:00.
Ardour session start at 00:00:00:00, I tried to change it but I didn’t find preferences or windows to help me for that.
I would like to change the start to 58:30:00:00 so I can put the one minute tone reference, the 10sec beep for the start count down and the 2sec beep.
At 01:00:00:00 I would like to start running the video synched to Ardour.
Actually the .mov file internal Time Code is 00:00:00:00, so what I would like to do, and is a standard way to work in film, seems simply impossible.

I would like to know any experiences from other users, how do you sorted out these requests and if there’s any videofile bringing TimeCode like the audio Broadcast Wave File and so on.
I just would like to know if my idea to switch to Ardour is applicable or I have just forget about it and stay where I am.

Thanks in advance for your support.

The units used when dragging objects around are based on the current setting of the secondary transport clock. Right click on this clock to change the units it displays.

I don’t fully understand what you describe in (3) … it would be better to open this as a bug in the issue tracker, since that allows us to track the issue more efficiently and make sure that this gets resolved.

  1. there’s a start marker at 00:00:00:00 - just drag it to your preferred start; alternatively, Alt-l opens the location window and you can type in a specific start time.

  2. starting anywhere out beyond 12hrs will generally not work in current ardour releases.

  3. the preferences dialog contains a tab that allows you to set a SMPTE offset. its been years since i added this, and i don’t even recall what precisely what it does. however, i think it has some relevance to your situation when dealing with a soundfile stamped at 00:00:00:00. i would suggest playing with it.

  1. If I drag the start marker it shows bars and beat instead of time code location, I hope is just a matter of settings I don’t know.
    Using the Alt+L window it works fine for the purpose, but in that case the video file is stuck to 00:00:00:00 so I can see just a green window. I think is an offset issue with jadeo that I can sort out at all.

  2. well usually a video project start at 01hrs. Sometimes at 10hrs. I think it should be fine for a lot of works, even it should be sorted out.

  3. The SMPTE offset is a good start to synch with a video using its proper “stamped on video TC” with jadeo, but still we cannot add two minutes earlier to put tone references.
    Jadeo starts running at the beginning of the session (that is not the start marker) no matter what.
    In this case there’s a strange behaviour with the start marker. Changing the offset, in the Alt+L window there’s no way to but back the start marker. Typing 01:00:00:00 doesn’t do anything while with other timecodes does. Dragging the start marker at session starts works but doesn’t update the TC in the Location Window.

“The units used when dragging objects around are based on the current setting of the secondary transport clock.”

Man, thanks for that tidbit. I’ve wrestled with fixing tempos and the like a lot lately. Maybe that will help.

late reply…
I only just stumbled over this thread…

  1. A green xjadeo window usually mans that it has no frame to display for the given timestamp (or no files is loaded). Depending on xjadeo compile-time options: it should have a cross drawn accros the frame (per default) and can be black instead of green…

Check the timecode on xjadeo’s on-screen-display (press ‘s’ and ‘v’ key on the xjadeo window), that may help to see what’s going on.

  1. xjadeo does parse and use the start timecode if it is present in the video-file. eg. With a video-file starting at timecode 1:00:00.0, JACK transport (or MTC) needs to be at 1:00:00.0 for the first frame to be displayed.
    You can override that behaviour with the “-I” command line option, which makes xjadeo shift the first video-frame to 0:00:00.0

xjadeo can also add time-offsets: press ‘o’ to show the current offset on-screen. ‘+’ and ‘-’ to modify it. For larger offsets, you can pass it as parameter on the commandline: fi. -o -0:57:30:0 (or configure it the file $HOME/.xjadeorc )

I don’t exactly understand the problem that you describe in (3).
The start-marker in ardour is just a marker. It does not modify timecode.

The ‘session SMTPE offset’ in ardour’s preferences window works only with ardour’s internal-clock and MTC - not with JACK transport. Compare ardour’s clock display with that in qjackctl (xjadeo sees the same time as qjacktl). That is likely a bug or missing feature in ardour.