Files, created by Ardour, not recognized by any other programm...


I make new session, record sound. (I has tried Wave and broadcast wave) native format - if I open recorded sound (from Audiofiles), I can’t play it in any programm… Any idea?

MacOSX10.4.4, Ardour-0.99.2-tiger.dmg

Are you 100% sure that the programs you tried to open the sound files with are capable of loading floating point waves?

I think i answered you already on the email list, but I’ll repeat it here for posterity: this is a known issue with our current native file format on big-endian (PPC) platforms. We use the little known RIFX format at the moment.

The next point release will use the latest libsndfile which will make ardour capable of importing its own native format :slight_smile:

Ardour2 will soon be using different native formats (that also support larger file sizes) and this problem will disappear.

if you have audacity somewhere, you may be able to do some conversion as a temporary workaround.

If you have audacity on the target machine, lauch it, click on Project->Import Raw Data, grab your file and then you’ll get a popup with the possibility to choose a complete list of format paramaters (including endianess, choose little endian)

Once imported, you can export you new file as wav and it should get a big endian file.

Does someone have a mac to try this ?