Fileprocessor replacement


(Daniele1971) #1

Hello guys, first time here :slight_smile: So, coming from Lmms I badly miss the Fileprocessor pluigin, is there an alternative ?
I tried with linuxsampler but it’s complicated and does not work with a single sample.
The sampler from Lsp plugins but requires a sample for each note.

So is there a way to play a single sample like a midi ?

Thanks and sorry for my bad english :slightly_smiling_face:

Daniele.


(Edward Diehl) #2

Have you tried samplev1?: https://samplv1.sourceforge.io/


(Daniele1971) #3

Todo list :wink: Tested now, it should be ok, works standalone but inside ardour, empty window without controls or Ardour crashes (segfault) :confused:


(Paul Davis) #4

Where did you get (1) Ardour (2) samplev1 from? This behavior normally indicates an incorrect build of one or the other or both.


(Daniele1971) #5

I’m using opensuse tumbleweed, Ardour from Multimedia repo and samplev1 from website (precompiled rpm).


(Paul Davis) #6

Grab the free/demo copy of Ardour from http://ardour.org/download … it will almost certainly not have this problem. You can install it (and use it) without removing the distro-supplied version.


(Daniele1971) #7

Exactly the same :frowning:
But I found this: suil error: Unable to open UI library /usr/lib64/lv2/samplv1.lv2/samplv1_ui.so (/usr/lib64/libQt5Gui.so.5: undefined symbol: hb_font_funcs_set_nominal_glyph_func)

hb_font_funcs_set_nominal_glyph_func() is part of hurfbuzz


#8

Problem is described here at the bottom

http://www.rncbc.org/drupal/node/1918


(Daniele1971) #9

Yeah ! Thanks, now it’s working as expected ! Problem solved.


(Daniele1971) #10

Maybe I spoke too early, I need to reload the sample (or preset) everytime I open a project :frowning:
Hard to work in this way :confused:
Any hints ?


(Daniele1971) #11

It was a bug in Samplv1, fixed in 0.9.4.