Feedback/static in recording, intermittent

I am experiencing a strange issue when recording with Ardour. We are recording 3 microphones (Audio-techinca AT2020 USB), each on a separate track, and everything will be going along skippy. Randomly I will hear what sounds like feedback and an echo in the monitor and when I watch the waveform I can see that the sound is coming in twice. It seems to come in partially each time and almost seems like an issue of the information being captured in Ardour correctly. It is quite literally repeating everything and it effects each track.

We have had this happen on several machines in the past though it was a rare issue that was solved by a restart of the program. We have started to use a new computer and now it consistently happens every time, sometimes almost immediately and sometimes after 15-20 minutes of recording. I have tried adjusting the latency on both Ardour and Jack to see if that would fix the issue but it doesn’t seem to have an impact on it. I have started Jack before and after starting Ardour as well as not launching it at all with no change. Does anyone know what would be causing that to happen? I am on a brand new computer so it could be a system setting but I have gone everywhere that I would normally look and simply can’t diagnose where its coming from. Please help.

Not something I have ever heard of happening before, I would bet you are somehow routing in such a way to cause this, but I am unsure of what exactly. OS X’s aggregate device functionality is known to have issues and it is more than possible that you are running against a new one, it is not one I have heard of before but it is possible I suppose.

Really Ardour and Jack both are designed to work with professional workflows. If you need to record 3 mics at once, you really should be using a single interface and not three seperate interfaces with three seperate clocks, which is effectively what you are doing now by using three USB mics.


I can understand how running multiple mics could cause part of the issue but the thing is that we have been doing this on multiple computers of equal and lesser processing power for nearly a year now with little trouble. What could it be do you think in the aggregate settings that could be pissing Ardour off so badly? Any ideas in the settings in Jack or Ardour that might alleviate this?

I am trying to exhaust all of our software setting options first since we are currently running everything via USB mics and to get a mixer would be an exercise in converter cables and plugs to route the 3 audio streams into the computer as one steam. That is unless anyone knows of a mixer that accepts USB inputs for the mics as well as/instead of the 1/4" plugs that I have seen that then output it all to one USB cord.

@steveo157: its not multiple mics. its multiple audio interfaces. when you use these solely with coreaudio-native software, the software will ask coreaudio to do sample rate adjustments to keep each interface in sync with the others. JACK doesn’t do this (primarily because this is an “unprofessional” way to work) and so the issues with the multiple interfaces becomes more noticeable. The basic rule of digital audio is that there should be a single sample clock that controls all devices. Most USB interfaces do not allow the use of an external clock source, so this is impossible to do with most of them.


I can’t say for certain what is causing it unless I can see an entire session with source files that demonstrates this. Even then I might not, but it would give me a better guess.

As Paul mentioned, the issue isn’t the using of multiple mics, but rather the lack of using a single interface. Also most interfaces youa re not combining the three mics down into one signal, you would still record all three mics individually in Ardour(Or any program). As you mentioned you can’t do this easily with your current mics as they are all USB mics unfortunatly, but this is a very odd(And many would say very poor) workflow in general as there is no single clock source, and you will have issues. These USB mics are really designed to only use one at a time to record basic podcasts etc, that is about all they are good for. When you are recording multiple inputs at once, you really shouldn’t be using them.

At any rate, if you have a small session that demonstrates this phenomenon you can ZIP up the directory structure and post somewhere online for me to look at, I will take a look and see if I can come up with a clearer explanation of what is happening. Thanks.