Fedora 34 (Noise Repellent LV2) Dependency "lv2" not found

Having problems installing, it’s giving out the error below

Run-time dependency lv2 found: NO (tried pkgconfig and cmake)

meson.build:14:0: ERROR: Dependency "lv2" not found, tried pkgconfig and cmake

It’s not really an Ardour-related question but have you tried installing the lv2 package through your package manager before trying to compile again? It looks like it is available:
https://www.rpmfind.net/linux/RPM/fedora/34/x86_64/l/lv2-1.18.0-2.fc34.i686.html

You will also need (from the noise-repellent github README):

To compile and install this plug-in you will need the LV2 SDK, Meson build system (use pip3 to install it), ninja compiler, git and fftw3 library (>= 3.3.5 is recommended to avoid threading issues).

On fedora the packages you need for building software all have “-devel” at the end of the name, so to build an LV2 plugin you will need lv2-devel. Depending on how the plugin is written you may also need:
suil
suil-devel
serd
serd-devel
sord
sord-devel

The dnf info command can give details on those, but basically they are software packages to help with developing LV2 plugins.

$ dnf info suil
Last metadata expiration check: 0:03:04 ago on Wed 09 Jun 2021 09:40:43 AM CDT.
Installed Packages
Name : suil
Version : 0.10.8
Release : 2.fc34
Architecture : x86_64
Size : 223 k
Source : suil-0.10.8-2.fc34.src.rpm
Repository : @System
From repo : fedora
Summary : A lightweight C library for loading and wrapping LV2 plugin UIs
URL : http://drobilla.net/software/suil/
License : MIT
Description : suil makes it possible to load a UI of any toolkit in a host using any other
: toolkit (assuming the toolkits are both supported by suil). Hosts do not need
: to build against or link to foreign toolkit libraries to use UIs written with
: that toolkit (suil performs its magic at runtime using dynamically
: loaded modules).

Looking at the README file in noise repellent it does not appear to need the suil/serd/sord tools, so just install lv2-devel and fftw-devel to start, and try rebuilding to see if it complains about anything else that is not listed in the readme file.

They should come right from the repo?

on my system:
rpm -qa | grep lv2
lv2-1.18.0-2.fc34.x86_64
lv2-devel-1.18.0-2.fc34.x86_64
lv2-guitarix-plugins-0.42.1-4.fc34.x86_64

Yes, this is what I have on my machine:
$ rpm -q lv2-devel
lv2-devel-1.18.0-2.fc34.x86_64
$ rpm -q fftw-devel
fftw-devel-3.3.8-10.fc34.x86_64

I have lots of other development packages, but according to the README file those are the only two which should be needed for Noise Repellent (other than the standard compiler libraries).